Pin 13 blinks 7 times before running, when on USB

Hello, I have an Arduino Nano 3.0 with ATmega328, and it's recently developed an annoyance of blinking pin 13 7 times (maybe ~0.7s / blink) before running the program. This only happens when it's plugged in to my PC for power; I tried it with a 9V, then plugging the USB into a plain wall-wart, then (and here's the weird part) plugging it into a DIFFERENT computer... and it worked fine for all of the above.

I tried isolating the Nano from all the other circuitry, and uploading the blink sketch (with a 1s delay so I can tell the difference), but got the same result. It wasn't doing this before; does someone know what may have caused it and/or how to fix it?

The 1.6.8 IDE had / has an issue that it gave additional resets. Any chance that that is the case?

Except for power-on reset, using a usb charger or external power supply does not cause additional resets. It's definitely the PC that activates the reset line between the FTDI chip and the 328.