Pin 13 Light On

Hi, I was using my arduino as normal, and it was working fine. I have the arduino mega, got it pretty recently. But now, it does something weird when I try to upload a sketch. When I click the upload button, the TX and RX and pin 13 lights blink like normal for a second, and then they stop and the pin 13 light stays on. This is really weird, because then my laptop continues to tell me it is uploading the sketch while the light stays on. After a while if I press the reset button, the pin 13 light blinks twice, then goes off (ON light is still on). Can someone help me?

Thanks in advance -Dylan

what operating system are you using, as this will help us try to figure out where the problem is? Which version of IDE? Is this a homebrew sketch or a basic one? Does this happen if you load a Blink sketch in?

I'm running Windows 7. I believe Arduino 0022. It's the normal IDE. I tried with the blink sketch and it worked! Not sure what the problem was, but it was only with that one sketch. Maybe because I wanted to print and write to the LCD at the same time???? I don't know, but know it works. :D

Thanks for the help, -Dylan