PIR Motion Sensor - Lots of False Positives... Any Ideas why?

Okay, I have this PIR Motion Sensor from Radio Shack: http://www.radioshack.com/product/index.jsp?productId=2906724

I have it setup in a alarm system, to detect motion. The problem is the PIR Sensor is giving me a lot of false positives. It's set off about once every hour or so, when there absolutely no motion around.

This PIR Sensor is a little different, because when triggered, the pin goes HIGH, and most other PIR Sensors go LOW...

Does anyone have any ideas on what is causing this and how to fix it? I'm not sure what is causing the problems here, but any help would be great!

lol, and the alarm just got set off right now while writing this... ugh... HELP!?! lol

No tech info seems available on this part.

Suggest a different part, one with adjustable sensitivity.

From Mouser.com: 692-ZEPIR0AAS02MODG ZiLOG Multiple Function Sensor Development Tools ZMOTION Detect Mod US HTS: 9030820000 ECCN:3A991.a.2 COO:IL

Tech Info is here: http://www.radioshack.com/graphics/uc/rsk/Support/ProductManuals/2760033_PM_EN.pdf

It is made by Parallax.

Tells you nothing.

The better link on the page is a dead end

http://www.parallax.com/detail.asp?product_id=555-28027

Go Here:
http://www.parallax.com/StoreSearchResults/tabid/768/txtSearch/555-28027/List/0/SortField/4/ProductID/83/Default.aspx

Also note: I have the old revision… Not the newest one…

You don't have many options with that part.

"Detection range up to 15 ft away on short setting, up to 30 ft away on long setting "

Try changing the range setting.

"Power requirements: 3 to 6 VDC; 12 mA @ 3 V, 23 mA @ 5 V "

Try changing the power provided

Try blocking part of the field of view with a paper mask or something.

The Mouser/Zilog part: Has a pin to attach a light sensor for no daylight tripping Has adjustable sensitivity Has adustable On time when tripped

http://www.zilog.com/docs/PB0223.pdf