PL2303HX programmer not responding


I'm trying to upload sketches to an Atmega328-PU with the Arduino IDE. The microcontroller already has the boot loader installed, I can upload sketches when I use the FTDI chip from the arduino (Like said here:

Now I have a PL2303HX chip ( The pin layout from top to bottom: 3.3v, 5, GND, RXD, TXD. The top three pins above the chip are a mystery to me, but it seems like they change the serial signal power between 3.3v and something else (2.5v?).

The problem is that when I connect everything to my atmega (Power, ground, PL2303 RXD to Atmega TXD, PL2303 TXD to Atmega RXD) and try to upload sketches, the Arduino IDE gives me the programmer not responding error. When uploading I hold the reset on the atmega first, let the IDE compile and as soon as it says uploading I release reset. No luck though.

I tried switching the jumper, or removing it all together. Every post I find on the internet just seems to state it either works, or I should hold the reset button (Which I already do..) Is there anything I'm doing wrong?

If needed I can upload some pictures of the atmega circuit as well. If there's anything else your welcome to ask as well.

Thanks in advance :)

Try to play more with timing - eg to release a bit sooner or later. Better though to solder DTR leg through 100n capacitor to reset - that will do the reset magic for you. According to datasheet it should go from second leg of the chip so if you can trace it to some place where it could be soldered... On the other hand I was doing reset manually when dtr was wired to the other chip and never failed to hit - avrdude is quite tolerant to the timing. have you tried the pl elsewhere to confirm it actually works? for instance on some serial communication example sketch uploaded through ftdi?

I tried playing with the timing, it didn't work unfortunately. Soldering the DTR leg has been on my mind, but the PL2303HX is a SMD. I have never soldered SMD before, so I'm scared I'll ruin the chip. Thanks for the input though, I think I can ask someone around here to help me with the SMD.

Unfortunately, your image on "imgur" appears to be highly toxic to my browser or picture viewer (crashes Xwin), so I cannot see what sort of PL2303 module you are using.

You say it works fine with the FTDI chip. It should then be quite possible to manually upload or indeed to use the PL2303 chip. Does it not have DTR brought out to a "thru" on the board already? I suppose the five pin variants do not, by and large.

As to the timing, you do not need to hold the reset down for a long time. Just briefly press it when you see the "Binary sketch size: xxxx bytes (of a 30720 byte maximum)" message.

And - just in case, - try not crossing over TXD and RXD!

I have PL2303 and CP2102 modules and I am pretty sure one of them did NOT require the tx/rx line to be crossed. I just can't remember which was which and don't have access to them at the moment.

As Paul says, try taking tx>tx and rx>rx and see what happens.

well, on my PL i'm crossing - tx to rx and rx to tx, but mine is resoldered from nokia cable, so it's real rx and real tx, while the board could indeed have marking fore remote rx and tx (that is already crossed)

You may also wish to install the latest driver...

This is absolutely necessary for Windows systems that have been OS upgraded in the last year.