Please help Another Error message

I build an arduino board. It was a lot of fun. But I am now facing tons of problems. To begin with, after the assembly was completed, I tried uploading the analogue>fading example to check my board but it gave me an error message:

Binary sketch size: 950 bytes (of a 7168 byte maximum)

avrdude: stk500_getsync(): not in sync: resp=0x00 avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

When I ask you guys about this problem, some good friend of ours suggested that I should burn bootloader which I didn't do earlier. Now, in order to burn bootloader I build Parallel Programmer and connected it to the 2x3 ICPS pins. Now everytime I try to burn bootloader, I get this message:

avrdude: AVR device not responding avrdude: initialization failed, rc=-1 avrdude: Yikes! Invalid device signature. avrdude: Expected signature for ATMEGA8 is 1E 93 07 avrdude: AVR device not responding ***failed; avrdude: verification error, first mismatch at byte 0x0000 0x3f != 0x00 avrdude: verification error; content mismatch

I am using Arduino NG or older w/ATmega 8 setting. I build this board http://arduino.cc/en/Main/ArduinoBoardSerialSingleSided3 and I am using ATMEGA 8 chip, Is my setting for the board correct.

P.S. After connecting the Parallel programmer to my 2x3 pins, I noticed that the LED that I connected to my pin 13 is always turned on. Is this normal.

Help would be really appreciated. Thanks

anyone

It would be awfully helpful to know a few more things, not just the error messages.

  • operating system
  • what kind of parallel programmer, is is compatible with avrdude ?
  • full command line you use to burn the bootloader

more input !

Hello Madworm

I am using exactly the same board (single sided seral S3V3) as him.

My parallel programmer is built according to instructions in Hacking/ParallelProgrammer. I tested it with a multimeter and it is ok.

My operating system is Windows XP SP3, with the parallel parameter registry patch.

To try to write the bootloader I am using the IDE v016 with board set to Arduino NG w/ atmega 168 (my controler is an ATMEGA168-20PU)

I receive almost the same error message at byte offset 0x0000.

What could be the cause?

BTW, What is the correct BIOS configuration for the parallel port? EPP or ECP?

Thanks in advance, :)

Did you power the board ?

The dapa programmer does not come with a 5V power line.

http://my.opera.com/CrazyTerabyte/blog/2007/10/26/first-contact-with-atmega8-microcontroller-part-2

Ola MadWorm, tudo bom?

The board is powered by a 12V switched power supply (DC in 2.1mm connector).

I don't know if it is relevant but the pin 13 led is always fully ON during my write attempts, without blinking. If I remove the ICSP connector it goes off.

I am reading carefully the site you sent me... is it worth to build another type of cable to try to solve this problem? Or maybe its better to try another software like uisp instead of avrdude?

Brigadao pela resposta rapida :-)

Hello again,

I have great news :-)

I was wondering on the fact that not all board versions have an onboard LED on pin 13 like this one I am using (Single Sided Serial S3V3).

It is wierd... when the ICSP connector is plugged, that LED is lit even with the main power disconnect so I decided to give a try and remove the LED ... and it worked!

I was able to upload the bootloader smoothly and everything is now working like a charm.

The LED was stealing signal from the ICSP causing errors in the communication.

I think this is the reason why some people is only able to program this board with those STK200 clones with a 74244 acting as an amplifier.

Hope this helps people with similar problems.

I'm curious. What kind of LED did you use? That could make a difference.

Follow up: I made one of my own to see if I could reproduce your issue. I'm afraid I could not duplicate it.

http://pwillard.com/?p=88

It must be your diode. Did you use a Blue or White LED perhaps?

Hello :-)

I have used a 3mm red led identical to the power led in your board.

After uploading the bootloader, I have soldered the led back to the board for normal use, re-tested and the problem is back... it can't even read the device signature with the LED connected.

Maybe the problem is not the led itself but the combination with a dirty cheap onboard parallel port that causes the error. I used an old desktop with a Foxconn MB, unfortunately I currently don't have any other PCs with parallel ports available for testing... but I will post the results when I test.

It sure sounds like your LED closes a connection to a SHORT somewhere that should not be there... check your solder for bridges?

@mauriciobs wow...I'll give it a try I am having the very same problem with ICSP...will let you guys know if this helps me...thanks

Hello guys, how are you?

@pwillard: I would like to give you some feed back, in the meanwhile I have constructed a second arduino that has the same problem and can be work-arounded exactly the same way. I am pretty convinced it is a parallel port problem thought I haven't had the opportunity to test on another desktop yet. Thanks a lot for the support :) BTW: cool blog.

@mrwho: how is it doing? Did you managed to make yours work?

Best regards,

@mauriciobs,

I did remove the LED but now I am having a very weird problem....my board setting from the Tool option is "Arduino NG w/ ATMEGA 8" since my micro controller is ATMEGA8L-8PU but everytime I try to burn the bootloader I get this message "Wrong microcontroller found"....I have nooo clue what is wrong now!!.

Any Ideas~!!! :-?

Hi,

i have a Parallel programmer, dedicated to programming Atmega16, and i have wired the needed pin outs to my Atmega8 on my breadboard, and also attached a USB<->Serial interface and connected to RXD and TXD. And i think that should be a simple arduino (Arduino Expert version somehow).

I can read the signature successfully with CodeVision and can program and read from chip just nice.

but when trying Arduino 0016 with
Arduino NG or elder w Atmega8
w/Parallel programmer,

i get these errors:

avrdude: AVR device not responding
avrdude: initialization failed, rc=-1
avrdude: Yikes!  Invalid device signature.
avrdude: Expected signature for ATMEGA8 is 1E 93 07
avrdude: AVR device not responding
 ***failed;  
avrdude: verification error, first mismatch at byte 0x0000
         0xca != 0xff
avrdude: verification error; content mismatch

I don’t get where i am mistaking, i attach a picture of my (messy!) setup, please take a look and let me know:
(The Other resistors, capacitors are not related , and are for my other project, 8-))