please help having a hard time with library examples

keep getting these kinda errors, my libraries in the wrong place? trying to get a servo work

This report would have more information with
"Show verbose output during compilation"
enabled in File > Preferences.
Arduino: 1.0.6 (Windows Vista), Board: "Arduino Uno"
C:\Users\gregory\Documents\Arduino\libraries\Servo\Servo.cpp: In function 'void handle_interrupts(timer16_Sequence_t, volatile uint16_t*, volatile uint16_t*)':
C:\Users\gregory\Documents\Arduino\libraries\Servo\Servo.cpp:81: error: 'LOW' was not declared in this scope
C:\Users\gregory\Documents\Arduino\libraries\Servo\Servo.cpp:81: error: 'digitalWrite' was not declared in this scope
C:\Users\gregory\Documents\Arduino\libraries\Servo\Servo.cpp:88: error: 'HIGH' was not declared in this scope
C:\Users\gregory\Documents\Arduino\libraries\Servo\Servo.cpp:88: error: 'digitalWrite' was not declared in this scope
C:\Users\gregory\Documents\Arduino\libraries\Servo\Servo.cpp:92: error: 'clockCyclesPerMicrosecond' was not declared in this scope
C:\Users\gregory\Documents\Arduino\libraries\Servo\Servo.cpp: At global scope:
C:\Users\gregory\Documents\Arduino\libraries\Servo\Servo.cpp:232: error: 'boolean' does not name a type
C:\Users\gregory\Documents\Arduino\libraries\Servo\Servo.cpp: In constructor 'Servo::Servo()':
C:\Users\gregory\Documents\Arduino\libraries\Servo\Servo.cpp:249: error: 'clockCyclesPerMicrosecond' was not declared in this scope
C:\Users\gregory\Documents\Arduino\libraries\Servo\Servo.cpp: In member function 'uint8_t Servo::attach(int, int, int)':
C:\Users\gregory\Documents\Arduino\libraries\Servo\Servo.cpp:263: error: 'OUTPUT' was not declared in this scope
C:\Users\gregory\Documents\Arduino\libraries\Servo\Servo.cpp:263: error: 'pinMode' was not declared in this scope
C:\Users\gregory\Documents\Arduino\libraries\Servo\Servo.cpp:270: error: 'isTimerActive' was not declared in this scope
C:\Users\gregory\Documents\Arduino\libraries\Servo\Servo.cpp: In member function 'void Servo::detach()':
C:\Users\gregory\Documents\Arduino\libraries\Servo\Servo.cpp:281: error: 'isTimerActive' was not declared in this scope
C:\Users\gregory\Documents\Arduino\libraries\Servo\Servo.cpp: In member function 'void Servo::write(int)':
C:\Users\gregory\Documents\Arduino\libraries\Servo\Servo.cpp:292: error: 'map' was not declared in this scope
C:\Users\gregory\Documents\Arduino\libraries\Servo\Servo.cpp: In member function 'void Servo::writeMicroseconds(int)':
C:\Users\gregory\Documents\Arduino\libraries\Servo\Servo.cpp:300: error: 'byte' was not declared in this scope
C:\Users\gregory\Documents\Arduino\libraries\Servo\Servo.cpp:300: error: expected `;' before 'channel'
C:\Users\gregory\Documents\Arduino\libraries\Servo\Servo.cpp:301: error: 'channel' was not declared in this scope
C:\Users\gregory\Documents\Arduino\libraries\Servo\Servo.cpp:309: error: 'clockCyclesPerMicrosecond' was not declared in this scope
C:\Users\gregory\Documents\Arduino\libraries\Servo\Servo.cpp: In member function 'int Servo::read()':
C:\Users\gregory\Documents\Arduino\libraries\Servo\Servo.cpp:320: error: 'map' was not declared in this scope
C:\Users\gregory\Documents\Arduino\libraries\Servo\Servo.cpp: In member function 'int Servo::readMicroseconds()':
C:\Users\gregory\Documents\Arduino\libraries\Servo\Servo.cpp:327: error: 'clockCyclesPerMicrosecond' was not declared in this scope

midmofarmer:
keep getting these kinda errors, my libraries in the wrong place?

Quite possibly.

Make sure any new libraries are in the same subdirectory as the original libraries. Re-start the IDE seo thta it can find the files.

midmofarmer:
keep getting these kinda errors, my libraries in the wrong place? trying to get a servo work

What are you doing?

Normally you'd start the IDE, then open the example from the menu "File-Examples-Servo" and then select "Knob" or "Sweep".

Problems with that?

yep same errors, i had the same problem with sparksoft lcd library a while back, then figured out a trick to it, but now i can't remember what it was

midmofarmer:
yep same errors, i had the same problem with sparksoft lcd library a while back, then figured out a trick to it, but now i can't remember what it was

Why do you have this library in this library path:
C:\Users\gregory\Documents\Arduino\libraries\Servo\Servo.cpp
Looks like a wrong place to me.

In the "...\Documents\Arduino\libraries" path there should ONLY be the ADDITIONAL libraries you install from a third-party-source. Libraries that don't come with Arduino and are installed by the user.

To me it looks like as if the "arduino software installation path" and the "arduino documents path" is exactly the same and both reside in the same path
C:\Users\gregory\Documents\Arduino\

Did you do the software installation using the "Windows Installer" or the "ZIP file" version of Arduino?

If you are not very experienced, you most likely better chose the "Windows Installer" version, install Arduino from that, and delete the installation file from the "Documents\Arduino" path. Don't forget to save your sketches from your path before deleting it!

why doesn't the "sketch-add file..." not work it says "sketch is read only"

i can get blink to verify, but when i just add “#include <Servo.h>” get these errors again

This report would have more information with
“Show verbose output during compilation”
enabled in File > Preferences.
Arduino: 1.0.6 (Windows Vista), Board: “Arduino Uno”
C:\Users\gregory\Documents\Arduino\libraries\Servo\Servo.cpp: In function ‘void handle_interrupts(timer16_Sequence_t, volatile uint16_t*, volatile uint16_t*)’:
C:\Users\gregory\Documents\Arduino\libraries\Servo\Servo.cpp:81: error: ‘LOW’ was not declared in this scope
C:\Users\gregory\Documents\Arduino\libraries\Servo\Servo.cpp:81: error: ‘digitalWrite’ was not declared in this scope
C:\Users\gregory\Documents\Arduino\libraries\Servo\Servo.cpp:88: error: ‘HIGH’ was not declared in this scope
C:\Users\gregory\Documents\Arduino\libraries\Servo\Servo.cpp:88: error: ‘digitalWrite’ was not declared in this scope
C:\Users\gregory\Documents\Arduino\libraries\Servo\Servo.cpp:92: error: ‘clockCyclesPerMicrosecond’ was not declared in this scope
C:\Users\gregory\Documents\Arduino\libraries\Servo\Servo.cpp: At global scope:
C:\Users\gregory\Documents\Arduino\libraries\Servo\Servo.cpp:232: error: ‘boolean’ does not name a type
C:\Users\gregory\Documents\Arduino\libraries\Servo\Servo.cpp: In constructor ‘Servo::Servo()’:
C:\Users\gregory\Documents\Arduino\libraries\Servo\Servo.cpp:249: error: ‘clockCyclesPerMicrosecond’ was not declared in this scope
C:\Users\gregory\Documents\Arduino\libraries\Servo\Servo.cpp: In member function ‘uint8_t Servo::attach(int, int, int)’:
C:\Users\gregory\Documents\Arduino\libraries\Servo\Servo.cpp:263: error: ‘OUTPUT’ was not declared in this scope
C:\Users\gregory\Documents\Arduino\libraries\Servo\Servo.cpp:263: error: ‘pinMode’ was not declared in this scope
C:\Users\gregory\Documents\Arduino\libraries\Servo\Servo.cpp:270: error: ‘isTimerActive’ was not declared in this scope
C:\Users\gregory\Documents\Arduino\libraries\Servo\Servo.cpp: In member function ‘void Servo::detach()’:
C:\Users\gregory\Documents\Arduino\libraries\Servo\Servo.cpp:281: error: ‘isTimerActive’ was not declared in this scope
C:\Users\gregory\Documents\Arduino\libraries\Servo\Servo.cpp: In member function ‘void Servo::write(int)’:
C:\Users\gregory\Documents\Arduino\libraries\Servo\Servo.cpp:292: error: ‘map’ was not declared in this scope
C:\Users\gregory\Documents\Arduino\libraries\Servo\Servo.cpp: In member function ‘void Servo::writeMicroseconds(int)’:
C:\Users\gregory\Documents\Arduino\libraries\Servo\Servo.cpp:300: error: ‘byte’ was not declared in this scope
C:\Users\gregory\Documents\Arduino\libraries\Servo\Servo.cpp:300: error: expected `;’ before ‘channel’
C:\Users\gregory\Documents\Arduino\libraries\Servo\Servo.cpp:301: error: ‘channel’ was not declared in this scope
C:\Users\gregory\Documents\Arduino\libraries\Servo\Servo.cpp:309: error: ‘clockCyclesPerMicrosecond’ was not declared in this scope
C:\Users\gregory\Documents\Arduino\libraries\Servo\Servo.cpp: In member function ‘int Servo::read()’:
C:\Users\gregory\Documents\Arduino\libraries\Servo\Servo.cpp:320: error: ‘map’ was not declared in this scope
C:\Users\gregory\Documents\Arduino\libraries\Servo\Servo.cpp: In member function ‘int Servo::readMicroseconds()’:
C:\Users\gregory\Documents\Arduino\libraries\Servo\Servo.cpp:327: error: ‘clockCyclesPerMicrosecond’ was not declared in this scope

midmofarmer:
enabled in File > Preferences.

So in "Preferences" the "Sketchbook Folder" is most likely set to:
C:\Users\gregory\Documents\Arduino

But where install folder of the Arduino software?
In which folder is the "Arduino.exe" executable file located?

c:\program files (x86)\arduino and yea on the preferences sketchbook loacation

midmofarmer:
c:\program files (x86)\arduino and yea on the preferences sketchbook loacation

Are you executing Arduino as an "Administrator" user or as "Standard User"?

And how did you manage, that Arduinos default libraries are now in your sketch folder:
C:\Users\gregory\Documents\Arduino\libraries\Servo...
That's not whre the libraries should reside that come with the Arduino IDE.
It's the place for additional third-party libaries, added by the user.

With your installation path the Servo Library should exist in
c:\program files (x86)\arduino\library\Servo\

Do you have duplicate Servo libraries?
c:\program files (x86)\arduino\library\Servo...
C:\Users\gregory\Documents\Arduino\libraries\Servo...

i got over a dozen servo copies everywhere, maybe i need start fresh with another computer

That sounds like a very good idea. Go out and buy one tomorrow.

lol got an old windows xp, it still working good for arduino?

XP is that latest OS I have on all my computers, and Arduino is fine with it.

worked perfictally on the windows xp, why vista 64 bit throwing for a loop?

Who knows? I think you should start a new thread on that matter - after checking for any old ones.
Although, if you are running Vista, upgrading to XP is a smart and not unusual move, and may apply rather well in your case.