Please Help Me For Arduino Ide Showing Error While Compiling Sketch

I am Adding all the necessary Library.All The Connection perfetly fine . The Code Work Just fine In my Dektop PC.
But Giving Following Error While Compiling in my laptop. no information available for this error on net.
Please help me for this error.

Error : Archiving built core (caching) in: C:\Users\Yogesh\AppData\Local\Temp\arduino_cache_697818\core\core_esp8266_esp8266_generic_CpuFrequency_80,FlashFreq_40,FlashMode_dio,UploadSpeed_115200,FlashSize_512K64,ResetMethod_ck,Debug_Disabled,DebugLevel_None_____b857572a89a8d071b65f5b5b6efe602f.a

Arduino Ide version : 1.8.2
Board : generic ESP8266 Module
Port : COM3

Code :

#include <ESP8266WiFi.h>
#include <ThingerESP8266.h>

#define USERNAME "girish_vc86"
#define DEVICE_ID "ESP8266DEMO"
#define DEVICE_CREDENTIAL "moW7q9csxReH"

#define SSID "GVC_TECH"
#define SSID_PASSWORD "xxxxxxxxxxx"

ThingerESP8266 thing(USERNAME, DEVICE_ID, DEVICE_CREDENTIAL);

void setup() {
  pinMode(BUILTIN_LED, OUTPUT);

  thing.add_wifi(SSID, SSID_PASSWORD);

  // digital pin control example (i.e. turning on/off a light, a relay, configuring a parameter, etc)
  // thing["led"] << digitalPin(BUILTIN_LED);

  // resource output example (i.e. reading a sensor value)
  thing["millis"] >> outputValue(millis());

  // more details at http://docs.thinger.io/arduino/
}

void loop() {
  thing.handle();
}

Board Info :

BN: Unknown board
VID: 0403
PID: 6001
SN: Upload any sketch to obtain it

yogesh2591:
Error : Archiving built core (caching) in: C:\Users\Yogesh\AppData\Local\Temp\arduino_cache_697818\core\core_esp8266_esp8266_generic_CpuFrequency_80,FlashFreq_40,FlashMode_dio,UploadSpeed_115200,FlashSize_512K64,ResetMethod_ck,Debug_Disabled,DebugLevel_None_____b857572a89a8d071b65f5b5b6efe602f.a

That's not an error. It's just telling you the location of the core archive, not very useful information. That information will only be shown in the verbose compilation output in the next release of the Arduino IDE. I know it's confusing that it's red, which is normally used for warnings or errors. I have requested that it be shown in white instead so hopefully that will be fixed too.