[Please help] [Not working]Connecting the Arduino Yun to WIFI

Im working on a MacBook Pro 10.9.4 using The latest Arduino 1.5.7 IDE.

When I try to connect the Arduino Yun to WIFI i am able to connect and it says to click on the link, it then takes me to arduino.local and nothing loads for several minutes. I uploaded the Wifi status sketch and it seems to work it prints out this:

Current WiFi configuration
SSID: Networkname
Mode: Client
Signal: 61%
Encryption method: None
Interface name: wlan0
Active for: 11 minutes
IP address: 192.168.1.122/255.255.255.0
MAC address: 90:A2:DA:F1:0E:77
RX/TX: 11/16 KBs

but when I'm in the network name ( my mac) and so is the Arduino when I try to connect to it using Arduino.local nothing loads. I also tried to ssh to root@arduino.local to see what happens and I get the following:

ssh: Could not resolve hostname arduino.local: nodename nor servname provided, or not known

I really need to get this working for a project I'm doing but I have no idea what the problem is.

Thanks in advance!

Have you tried to connect to your Yun through its mentioned IP address? (192.168.1.122)

kind regards,

Jos

Thanks for the reply,
Yes I have, the same thing happens as when I try to connect to arduino.local ..nothing loads :~

  1. Connect ethernet cable to Yun

  2. Uploaded the YunSerialTerminal sketch

output of:

ifconfig