Please, i need Gcode stepper help

I am strugglling with a project. I'm making my first CNC Machine using Arduino, CNC Shield, GRBL 0.9J and Universal Gcode Sender 2.6.
My problems are:
My homing cycle doesn't work;
When i the "return to zero" comand, the steppers go crazy and make loud noises
When i send Gcodes, the steppers only make a very weird noise and doesn't move.
When i jog, everything goes normal, but from the tutorials i've seen, my motors are working way too slow.
I have already asked for help on GitHub but i don't get any answer, and i don't know where else should i ask for guidance

I'm using Hard Limits and they work perfectly
My power supply is 12V / 20V. I've already tried a different one (24V / 15V) and i don't see any difference.
I replaced the Arduino Board, still nothing.
I used another CNC Shield, still nothing.
I tried Both GRBL 0.9 and 1.1 with Universal Gcode sender 2.0.6 and 1.0.9

I have also CNCd 2 machines.

You tell about noise. My guess is that the stepper ran into mechanical stop.

Have You set up the needed parameters in the Gcode sender? Speed, acceleration.......?
Jog the axels to their home, Xpos = 0, Ypos = 0, Zpos = 0. Reset the position in the Gcode sender. Then jog the axles to half the mechanical range and try "Return to zero".
In the jog control window You set XY-, resp. Z- step. For test moving I use 70 mm for XY and 30 mm for Z.
Below the 2 lines for jog step the third line says: Speed. I use 500. Look it up and check!

I've not implemented the limit swiches and not tried the homing yet.

You sure those stepper are getting enough amps?

I do.
I'm using DRV8825 drivers and my steppers max current is 1,7A. I did the math and i found a VREF of ~0.6A
My power supply is 24V / 15 A

If they have enough power, I don't really know what else would be wrong.

Thanks for the idea.
I've checked the UGS parameters, and tried what you tell me, but unfurtunely it still the same.
I'm sending a picture of my parameters

No problems man, i really appreciate the help. Beacuse i've tried almost everything and nothing seems to fix my problem.

Why do You send a screen shot covering the jog window?
I told You about a third line below XY resp. Z jog step line. Speed....
That line is good to use.
As I said, no homing here. Did You perform the test cycle I suggested?

I tried to increase the feed rate and made a hug difference in the way my steppers were responding, a huge Thanks

Good!
A tip.... Change the title and remove "quickly"! That kind of question makes all helpers irritated. There are many members and we help them all as fast as we can. There is no golden path for any member.
If urgency, nobody considers that. It's all because of insufficient project management.

I'll do it, and thanks once again

Fine. Then we understood each other.

Well done! Maybe even "need Gcode stepper help", if You feel like.
Your question and the replies is now a topic in the Arduino help library.
Now another members can search and find Your question, and its solution. That's the idea for this forum, build a library of help.

1 Like

I like this one. I'll use

1 Like

The only remaining problem is now with the homing Cycle.
Your tip was a great help, now my steppers are moving smooth and the noise sound very "healthier"
Thank you guys for your help.
I hope this can help others with similar problems.
When press "return to zero" now, the steppers do the right job and nomore weird noises

Study the background, the basics, the needed circumstances, settings, etc. needed for homing to work. I've not yet studied it deeper but I hesitated and did not activate it.
Hopefully some other helper has experience and know more.