Please upgrade your Yún - latest is 1.4.1

Hi everyone

another released of OpenWrt-Yun is available. You can download it from http://arduino.cc/en/Main/Software#toc8

1.4.1 is a bugfix release: 1.4 contained a bug that made the webpanel fail in certain situation. Bug was found by Blk19U0102: thank you :wink:

Compared to 1.3 this release contains:

The complete list of changes is available at openwrt-yun/ChangeLog at master · arduino/openwrt-yun · GitHub

soeey but the

new scripts extract-built-date and extract-built-date-from-sysupgrade-image

means that all the datas/files/configuration/packets installed via opkg are still in the new image after the upgrade?

No, that's another thing. If you wish to preserve your files, you should upgrade via the advanced configuration panel. The webpanel upgrade is still a destructive operation.

PLEASE remind that you can also upgrade the single packages. Type

opkg update
opkg list-upgradable
opkg upgrade NAME_OF_PACKAGE_1
opkg upgrade NAME_OF_PACKAGE_2
...

or

upgrade-all

if you've extended disk space using an sd card.

However, as a general advice, don't forget that some upgraded packages may require modified kernels (the "webpanel show build date in sysupgrade file" is one example).

How can you tell if you do have the lates version using CLI?
Thanks

File /etc/arduino/openwrt-yun-release contains the build date. It should match or be near the date specified in the ChangeLog

how do I get my version number?

i dont have file /etc/arduino/openwrt-yun-release

cat /etc/arduino/linino-arduino-release
built=Wed Aug 7 17:41:11 CEST 2013

uname -a
Linux Arduino 3.8.3 #8 Mon Aug 19 16:22:39 CEST 2013 mips GNU/Linux

ranma1988:
how do I get my version number?

i dont have file /etc/arduino/openwrt-yun-release

As well as the methods you have already used, you can

cat /etc/openwrt_release

You don’t have the openwrt-yun-release file because you are running the older, Linino firmware, forked from OpenWRT ‘Barrier Breaker,’ which the Yun originally shipped with in 2013. A new OpenWRTYun firmware, forked from OpenWRT ‘Attitude Adjustment’ was released April this year (2014).

cat /etc/openwrt_release 
DISTRIB_ID="OpenWRTYun"
DISTRIB_RELEASE="1"
DISTRIB_REVISION="r40431"
DISTRIB_CODENAME="attitude_adjustment"
DISTRIB_TARGET="ar71xx/generic"
DISTRIB_DESCRIPTION="OpenWRTYun Attitude Adjustment 1"

uname -a 
Linux yun1 3.3.8 #1 Fri Apr 11 07:16:38 CEST 2014 mips GNU/Linux

The versions reported by uname -a can be a little confusing, I guess because Linino was a different branch.

I am about to install the latest firmware. Hopefully all the version information has been updated consistently.

So... What is the procedure to follow if the upgrade kills Wifi? After following the instructions using the web panel (extract bin to sdcard and click Reset on the web interface), I am no longer able to access my Yun through the WIFI. The Yun does not set up the Arduino Yun 90A2DAF00022 Wifi link like it did when I first got it (and is supposed to again according to the instructions) and I am unable to access it at the 192.168.240.1 or the IP address I had assigned to it prior to the "upgrade." Unable to even bring up a connection with Console or Putty. I am able to upload sketches and the Blink sketch works, but the Console sketch in the Guide locks up when I try to send commands to light the LED (and the LED doesn't respond), and the Process sketch remains blank on the console (tried consoles on the COM port, 192.168.240.1, and 192.168.0.14 (my prior mapped IP)). All these sketches worked minutes prior to the upgrade. The only thing I did that may have been different than whatever was tested before this was released is I had set mine up to have a static IP (so I could port forward for external access). Other than that, I pretty much had just walked through all the tutorials (only got this yesterday).

And yes, I did wait until the WLAN LED stopped blinking during the upgrade - not a complete idiot :slight_smile: (but feeling a little stupid for choosing to upgrading a device that was working perfectly fine - anyone else considering this should THINK TWICE!).

What can I do besides return the Yun? I am guessing that the upgrade corrupted the Linux build and the bridge is no longer working. Is there any way to restore the original build?

Update: I also tried connecting via the wired LAN connection but although the WAN led blinked orange, no new devices were registered on the router and I was still unable to access the device.

Could my problem be I didn't install 1.4 first and tried to go straight from the stock version (w/o the openwrt-yun-release file) to 1.4.1?

I get an unknown does this mean I need to upgrade

root@Arduino:~# cat /etc/openwrt_release
DISTRIB_ID="Linino"
DISTRIB_RELEASE="devel"
DISTRIB_REVISION="unknown"
DISTRIB_CODENAME="barrier_breaker"
DISTRIB_TARGET="ar71xx/generic"
DISTRIB_DESCRIPTION="Linino Barrier Breaker devel"
root@Arduino:~# uname -a
Linux Arduino 3.8.3 #8 Mon Aug 19 16:22:39 CEST 2013 mips GNU/Linux

OK. poking around I found some tips from others who bricked their LInux. Below is the result I get when I reset the Yun while connected via USB serial. Looks like something is corrupt but I lack the knowledge to interpret and establish next steps.

U-Boot 1.1.4-gd995931a-dirty (Aug  7 2013 - 16:16:04)

Arduino Yun (ar9331) U-boot

DRAM:  64 MB
Top of RAM usable for U-Boot at: 84000000
Reserving 142k for U-Boot at: 83fdc000
Reserving 192k for malloc() at: 83fac000
Reserving 44 Bytes for Board Info at: 83fabfd4
Reserving 36 Bytes for Global Data at: 83fabfb0
Reserving 128 forbootparas() a: 838bfb
Stak Poiter a: 838bf9
Now running in RAM - U-Boot at: 83fdc000
Flash Manuf Id 0xef, DeviceId0 0x40, DeviceId1 0x18
flash size 16777216, sector count  256
Flash 16MB
Using default environment

In:    serial
Out:   serial
Err:   serial
Net:   ag7240_enet_initialize...
No valid address in Flash. Using fixed address
No valid address in Flash. Using fixed address
: cfg1 0x5 cfg2 0x7114
eth0: 00:03:7f:09:0b:ad
eth0 up
: cfg1 0xf cfg2 0x7214
eth1: 00:03:7f:09:0b:ad
athrs26_reg_init_lan
ATHRS26: resetting s26
ATHRS26: s26 reset done
eth1 up
eth0, eth1
Hit any key to stop autoboot:  4  3  2  1  0 
## Booting image at 9fea0000 ...
   Image Name:   MIPS OpenWrt Linux-3.3.8
   Created:      2014-08-07  10:42:20 UTC
   Image Type:   MIPS Linux Kernel Image (lzma compressed)
   Data Size:    1185655 Bytes =  1.1 MB
   Load Address: 80060000
   Entry Point:  80060000
   Verifying Checksum at 0x9fea0040 ...OK
   Uncompressing Kernel Image ... OK
No initrd
## Transferring control to Linux (at address 80060000) ...
## Giving linux memsize in bytes, 67108864

Starting kernel ...

[    0.000000] Linux version 3.3.8 (jenkins@jenkins) (gcc version 4.6.3 20120201 (prerelease) (Linaro GCC 4.6-2012.02) ) #1 Thu Aug 7 12:39:46 CEST 2014
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU revision is: 00019374 (MIPS 24Kc)
[    0.000000] SoC: Atheros AR9330 rev 1
[   0.00000]Clocs: CP:400.00MHz DDR400.00MH, AHB200.00MH, Ref25.00MHz
    .00000] Dtermied pysica RAMmap:
[    .00000] memor: 0400000@ 0000000(usabe)
[    0.000000] Initrd not found orempty- disblin inird
[   0.0000] Zoe PF rangs:
[   000000]   ormal  0x000000 ->0x0004000
[   0.00000] ovabl zon star PFNfor ech noe
    000000] Ealy mmory FN rages
[    .00000]    0:0x0000000-> 0x000400
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 16256
[    0.000000] Kernel command line:  board=Yun console=ttyATH0,250000 mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,14656k(rootfs),1280k(kernel),64k(nvram),64k(art),15936k@0x50000(firmware) rootfstype=squashfs,jffs2 noinitrd
[    0.000000] PIDhashtableentris: 25 (oder: 2, 104 byts)
[    .00000] Dntry achehashtableentris: 892 (rder:3, 3268 byes)
[   0.00000] Iode-achehash able ntrie: 406 (oder: , 1634 btes)
[    0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
[    0.000000] Writing ErrCtl register=0000000
[   0.0000] Reaback rrCt regiter0000000
[    0.000000] Memory: 60936k/65536k available (2565k kernel code, 4600k reserved, 650k data, 180k init, 0k highmem)
[    0.000000] SLUB: Genslabs=9, HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[    0.000000] NR_IRQS:51
[    0.000000] Calibrating delay loop... 265.42 BogoMIPS (lpj=1327104)
[    0.080000] pid_max: default: 32768 minimum: 301
[    0.080000] Mount-cache hash table entries: 512
[    0.080000] NET: Registered protocol family 16
[    0.090000] gpiochip_add: registered GPIOs 0 to 29 on device: ath79
[    0.090000] MIPS: machine is Arduino Yun
[    0.530000] Setting DogStick2 GPIO
[    0.550000] bio: create slab <bio-0> at 0
[    0.550000] SCSI subsystem initialized
[    0.560000] usbcore: registered new interface driver usbfs
[    0.560000] usbcore: registered new interface driver hub
[    0.560000] usbcore: registered new device driver usb
[    0.570000] Switching to clocksource MIPS
[    0.570000] NET: Registered protocol family 2
[    0.570000] IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.580000] TCP established hash table entries: 2048 (order: 2, 16384 bytes)
[    0.580000] TCP bind hash table entries: 2048 (order: 1, 8192 bytes)
[    0.580000] TCP: Hash tables configured (established 048 bnd 248)
[    .58000] TP reo regstere
[   0.8000] UDPhash able ntres: 26 (orer: 0 409 byts)
[   0.90000 UD-Litehash able ntris: 26 (orer: 0 4096byts)
[   059000] NET Reisterd proocol amil 1
[    0.610000] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.610000] JFFS2 version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.620000] msgmni has been set to 119
[    0.620000] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 254)
[    0.620000] io scheduler noop registered
[    0.630000] io scheduler deadline registered (default)
[    0.630000] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled
[    0.640000] ar933x-uart: ttyATH0 at MMIO 0x18020000 (irq = 11) i{ a AR933X UART
[    0.640000] console [ttyATH0] enabled, bootconsole disabled
[    0.640000] console [ttyATH0] enabled, bootconsole disabled
[    0.650000] m25p80 spi0.0: found w25q128, expected m25p80
[    0.650000] m25p80 spi0.0: w25q128 (16384 Kbytes)
[    0.650000] 7 cmdlinepart partitions found on MTD device spi0.0
[    0.660000] Creating 7 MTD partitions on "spi0.0":
[    0.660000] 0x000000000000-0x000000040000 : "u-boot"
[    0.660000] 0x000000040000-0x000000050000 : "u-boot-env"
[    0.670000] 0x000000050000-0x000000ea0000 : "rootfs"
[    0.670000] mtd: partition "rootfs" set to be root filesystem
[    0.670000] mtd: partition "rootfs_data" created automatically, ofs=7B0000, len=6F0000 
[    0.680000] 0x0000007b0000-0x000000ea0000 : "rootfs_data"
[    0.680000] 0x000000ea0000-0x000000fe0000 : "kernel"
[    0.680000] 0x000000fe0000-0x000000ff0000 : "nvram"
[    0.690000] 0x000000ff0000-0x000001000000 : "art"
[    0.690000] 0x000000050000-0x000000fe0000 : "firmware"
[    0.710000] ag71xx_mdio: probed
[    0.720000] eth0: Atheros AG71xx at 0xba000000, irq 5
[    1.270000] eth0: Found an AR7240/AR9330 built-in switch
[    2.300000] eth1: Atheros AG71xx at 0xb9000000, irq 4
[    2.850000] ag71xx ag71xx.0: eth1: connected to PHY at ag71xx-mdio.1:04 [uid=004dd041, driver=Generic PHY]
[    2.850000] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    2.850000] ehci-platform ehci-platform: Generic Platform EHCI Controller
[    2.860000] ehci-platform ehci-platform: new USB bus registered, assigned us nmber 
[    2.890000] ehci-platform ehci-platform: irq 3, io mem 0x1b000000
[    2.910000] ehci-platform ehci-platform: USB 2.0 started, EHCI 1.00
[    2.910000] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002
[    2.910000] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    2.910000] usb usb1: Product: Generic Platform EHCI Controller
[    2.920000] usb usb1: Manufacturer:Linux3.3.8ehci_cd
    .92000] us usb1 SeialNmber:ehci-latfom
[    2.920000] hub 1-0:1.0: USB hub found
[    2.920000] hub 1-0:10: 1 ort dtecte
[   2.30000 Initaliing UB Mas Storge drver..
[   2.30000 usbore:regisered ew inerfce drver ub-strage
[   2.93000] SB Mas Stragesuppot regsterd.
[    2.93000] inut:gpiokeys-olledas /evics/plaform/pio-kys-plledinputinput
[    2.940000] sdhci: Secure Digital Host Controller Interface driver
[    2.94000] sdci: Cpyriht(c)Piere Ossan
    294000] uscore:regiterednew nterfce diverushc
[   2.94000] CP cuic reisteed
[   295000] NE: Regsterd proocol amil 17
    .95000] Bidgefirewllingregitere
[   2.90000]8021: 8021Q VLN Suport 1.8
[    2.960000] VFS: Mounted root (squashfs filesystem) readonly on device 31:2.
[    2.960000] Freeing unused kernel memory: 180k freed
[    3.290000] usb 1-1: new high-speed USB device number 2 using ehci-platform
[    3.480000] usb 1-1: New USB device found, idVendor=058f, idProduct=6254
[    3.480000] usb 1-1: New USB device strings: Mfr=0, Product=1, SerialNumber=0
[    3.490000] usb 1-1: Product: USB2.0Hub
[    3.550000] hub 1-1:1.0: USB hub found
[    3.550000] hub 1-1:1.0: 4 ports detected
[    3.610000] SQUASHFS error: xz_dec_run error, data probably corrupt
[    3.610000] SQUASHFS error: squashfs_read_data failed to read block 0x456ae
[    3.610000] SQUASHFS error: Unable to read data cache entry [456ae]
[    3.620000] SQUASHFS error: Unable to read page, block 456ae, size 1516c
[    3.620000] SQUASHFS error: Unable o red dat cace enty [46ae]
[   3.62000] SUASHS errr: Uable o rad pae, blck 46ae, ize 516c
[   3.63000] QUASHS errr: Uable o red dat cace enty [46ae]
[    .63000] SUASHS errr: Uableto red pae, blck 46ae, ize 516c
[    .63000] SUASHS errr: Unble o red dat cach enty [45ae]
[    .63000] SUASFS eror: Uable o red pae, blck 45ae, ize 516c
[    .64000] SUASHS errr: Unble o red dat cach entr [45ae]
[   3.64000] SUASFS eror: Uable o red pae, blck 45ae, sze 516c
/bin/h: '/ib/lbc.s.0' i not n ELFfil
/bin/sh: can't load library 'libc.so.0'
[    3.760000] Kernel panic - not syncing: Attempted to kill init!

@TickTock, try with the uboot procedure. Skip the uboot part and start with the kernel http://arduino.cc/en/Tutorial/YunUBootReflash

@dsych007, yes your yun still has the old image

I tried that but it requires the wired ethernet port to work and that is not connecting either (never registers on the router and P2P doesn't work either). Does uboot have access to the sdcard? Can I put the three images there and reflash that way?

Let's move the conversation on the other topic then: http://forum.arduino.cc/index.php?topic=261471

I am starting to think my Yun is hopelessly lost without breaking out the soldering iron so I am returning here to see if we can figure out what happened and to ensure other people are aware of the risks involved. In my log posted above, you can see that there are quite a few errors in the serial stream. Missing characters, etc. Is it possible that a flakey serial1 connection can corrupt the update process? Make sense? Or completely irrelevant? Remember that the corruption happened without any serial terminal open - I just clicked the "Reset Yun using the found image" (or something like that - I can't remember exactly what it said) button on the web interface.

A problematic serial conn doesn't mess with the update process run through the webpanel because they work on different "terminal", so to speak

I ordered a second Yun which arrived today. The tftp procedure worked first try on the new device. Just to be sure, I tried the original again after that success and it still fails. Also, the new one doesn't seem to suffer from the missing characters in the monitor serial stream. Not sure if it is related, but thought I'd mention just in case. So to summarize: the upgrade procedure using the web interface corrupted the device beyond recovery (unless there is something else I can try that doesn't require ethernet).

Anyway, I am a lot more relaxed now that it is resolved and I have a device to work with. Going to return the bricked device tomorrow. Hopefully future upgrades will have a checksum and/or some other mechanism to prevent this sort of thing. Maybe keep the old image at an alternative location in the flash so it can be restored with minimal support?

I just followed the guide to update my Arduino Yun. Everything went well except that now, after 3 minutes and after the blue LED is no more lit (so apparently everything went well) my arduino is not showing any wifi. I have still the USB cable plugged in, I didn't unplugged it, and on the board, the only led lit is "ON". What I should do now?

EDIT:

After a talk with Federico, he explained to me that my Yun didn't reboot properly because of a sketch that was preloaded before updating that was using the Bridge. This sketch prevented the Linux boot, however the update process was OK. So, as Federico told me to do, I loaded the "yunserialterminal" sketch, rebooted the Yun manually by unplugging and plugging again the USB cable and voilá, the wifi reappeared again and now I have my Yun updated!

I sweated a little bit due to the fact that it was not written anywhere that you must load a "blank" sketch before updating, even this workaround was not written anywhere, but now I am very happy :slight_smile: Thanks Arduino Team!