Plugin not connecting in classroom, previously working

Hi, I have a class of about 30 students who are working on HP streams with Windows 10, running Create on the chrome browser. It has been working great, until yesterday all of my students received the yellow message at the top saying the there is no plugin connection. I talked to the IT person at my school who assured my the laptops have not received any updates or anything that would potentially cause the plugin to stop working.

Does anyone have any suggestions as to what I should do?

Sorry you are having issues but a little more information might help.

Were all the computers individually installed for the plugin ?
Did they all accept the certificate and allow any additional driver installs and local firewall permissions ?
Are they ALL using the same browser as only the browser for which the certificate was installed can be used IIRC ?
Are all the firewall permissions correctly set to allow the plugin ?
Has the schools router / firewall been told to accept the connections inbound and outbound ?

AFAIK there is not a shared certificate.

Is there is any additional information you can provide? ( this may help you as to the specific information )

Yes to all the questions - For the last two:

Are all the firewall permissions correctly set to allow the plugin ?
Has the schools router / firewall been told to accept the connections inbound and outbound ?

Nothing was explicitly done, although we have been using the plug in since December in chrome without a problem.

We are on Chrome version 56.0.2924.87 (64 bit), and when i checked the version number it actually updated it again to 57.0.2987.110, and I checked again, but it still did not work.

We also tried to install it on the desktop computer of our IT person. We were not able to get it to work with chrome, but it did work with Firefox.

Also, when we were adding it to firefox, we went through a step in the process we never saw when adding it on chrome. I have attached a screenshot of what we saw.

Yes you should have seen that screen for each individual browser you wanted to use with CREATE.
The certificate should be accepted otherwise you will see failures of the kind you are currently seeing.

Does your IT dept have and policies filters set in regards to chrome usage ?

The updates to chrome haven't shown any adverse affect here with CREATE so it is unlikely to be that.

Are all the plugins showing the same version (right click the plugin to see the version in grey)
The plugin should self update (as I just learned).
Mine shows "1.1.54-bba30de" currently.

If it works for firefox on an unrestricted computer (Usually that's what IT staff have LOL) then I do suspect a restriction issue in some form on the classroom computers.

Also check with your IT staff if there are any GPO in place (they will know what it means)

The laptops are not on a group policy, they have local user accounts - we had to do this in order to make web and desktop plugins work.

No known filters for chrome usage

It appears the plugin is still self updating to that version when opened, then resetting on restart.

After doing some testing, it does work on chrome on my personal laptop, although I did need to reinstall the plugin to make it work. Is there any reason why this was necessary?

Resetting on restart may still be some form of GPO or file restriction at your end to prevent students overwrite files.

Think there is a clue in that bit of info you just gave.
Maybe (semi guess) your IT needs to allow the plugin through properly to avoid the re set of the plugin.

Could be you are getting close to the problem.

Hi @aams86,
we are sorry for your issues.

Please check the version of the plugin installed on your students’ computers, it should be 1.1.54-bba30de.

Please run again the installation flow on each computer via the Getting Started flow, as each browser needs a specific certificate (as you noticed on Firefox).

Please let us know if this fixes your issue, we will try our best to get your classroom up and running again!

Hi,
My apologies, I realized I never followed up here. I think it ended up being some tweaks made on our end. The IT folks did something that broke it, and I think in the end they made some temporary changes to privileges on student laptops so we could fix it.

Thank you for your time and help!

Hi, on my UNO operating a program for sending data to the serial monitor. When I tried to load a new program, I did not succeed and now I can not connect to UNO. Serial port unavailable! I not sure is it PC or UNO problem?
What to do?

@ Raitis
Are you using the ONLINE editor ?

If so please read this section first and add any extra information you can.

I use web editor.

I am beginer. Some libraries codes test and successfuly. Then try some my self and successfuly too, one time.
When I try change other code, it long time not finish uploding and i try to stop it. After that I can no connect to module.

@ Raitis

I would request again that you read from the link I gave and add the information needed to help you.

I’m not strong computer skills, so it’ll give what I know

Windows 7 professional, 64 bit OS
Firefox 53.0.2 32-bit

I have not started working with desktop IDE, only web editor. Use Arduino UNO.

Yellow message appears in some moments:
No Plugin Connection. Uploading is disabled until you reconnect.

After that I install once more Arduino Create agent, but still no changes.

Problem: Arduino editor can’t connect to UNO.

I put my code, but it seems to me that the code is not guilty!?

Code still running on UNO and LCD show temperature!

! When started run code, serial TX led blinked according sent up data. After that event it not blinking!?

/* Temperature from LM35 to liquid cristal LCD and serial monitor

*/
#include<LiquidCrystal.h>
LiquidCrystal lcd(2, 3, 4, 5, 6, 7);
byte degree [8]=
{
  0b00011,
  0b00011,
  0b00000,
  0b00000,
  0b00000,
  0b00000,
  0b00000,
  0b00000
};

void setup() {
  analogReference(INTERNAL);
  lcd.createChar(1,degree);
  lcd.begin(16,2);
  Serial.begin(9600);
  pinMode(0,INPUT);
  
  lcd.setCursor(0,0);
  lcd.print("Temperature");
  lcd.setCursor(0,1);
  lcd.print("LM35");
  delay(2000);
  lcd.clear();
}

void loop() {
 float temperature=0.0;
 int sample;
 float x_samples=0.0;
 for(sample=0; sample<10; sample++){
   temperature=((float)analogRead(A0)*(1.1/1024.0))*100;
   delay(100);
   x_samples=x_samples+temperature;
 }
 temperature=x_samples/10.00;
 lcd.setCursor(2,0);
 lcd.print("Temperatura");
 lcd.setCursor(4,1);
 lcd.print(temperature);
 lcd.write(1);
 lcd.print("C");
 Serial.println(temperature);
 x_samples=0.0;
 }

What else might help solve the problem?

If that message appears just as you start to open the editor page that can be normal and I often see it here.

But here it goes away and then I can choose the board and port with no problem.

If you are unable to choose the board and port then it may well be that you missed something during the installation.

It needs to install a CERTIFICATE that has to be installed along with some drivers and quite possibly a firewall permission.

Firefox should have offered you a box with the certificate.

accept cert.jpg

Did you do that part ? and accept any other things it offered ?
BTW choosing the identify website option works and I think is mentioned in the step through.

I make this certificate installation the first time and after this event. I did it through all the steps, but warning still there.

I have the feeling that the web editor does not see this port, because when the installation for the first time, the editor already saw at the port which the UNO is connected, only choose it.
Editor currently only offers a choice of board without a specific port.

I change with mouse port and repeat getting started. Mouse working, board no.

What else could be?

if you only have one Arduino board the editor will only show that one port.
That is the port you will be using for that board.

You said you had already got some code working which would normally indicate a successful bridge between the plugin and the editor.

If you have anything connected to the board then please disconnect it and try again.
Some pins on the board are used for the serial communications and should not be connected to external hardware until after a sketch is uploaded. These are primarily pins D0 and D1.

I would request a screen shot of your device manager screen with the COM LPT port section expanded please.

You could also start the debugger from the bridge icon by right clicking and selecting “open debug console” That will bring up a mostly empty web page that will fill in as you try things. You can then copy and paste that output in here but please use the code tags ( </> ) provided and as explained in the thread I sent you to.

The logical sequence of events is as follows:

First installation of web editor - successful, after which started making some simple test codes from the library. They had several and UNO them executed, as necessary, each time was able to upload the new code, which wanted to test. One of them was by sending data to Serial Monitor, too.

Then I set up their own code of successful uploading and executing of the UNO.

When I try upload little change of that code, then the uploading took so long that I stopped the loading, after which nothing could be done.

After I make a new installation of certificate, and stepped out of the installation process, the unfortunate. Now we are here.

UNO still working with last my code and shows the temperature on the LCD. Hardware not changed since successful working. D0,D1 are free.

I think something has gone wrong in the event of sending data to the serial monitor and uploading new code through this port.

Sorry can't paste device manager picture, it could be attached!?

Yes attachments are allowed.

Can you link me to your sketch on the editor so I can maybe try it this end ?

That you "stepped out" of the complete process could have broken the process and you may have to go through it again but until completion.

Here in miracle, UNO connected and running again!!!

Upload other code, successful, but with warning!?

What does it mean??