poblema IIC/I2C/TWI SPI Serial 2.6" LCD 1604B

Como sou novo na area e nao encontro solucao ,
pesso ajuda aquem puder ajudar ,o lcd fica com 2 linhas pretas no lugar do caracteres fica os quadrados pretos ja tentei um monte biblioteca mas nao influencia em nada sera que ta queimado o so de ligar no 5v egnd a tela fica assim .
o modelo esse ,
http://www.dx.com/pt/p/arduino-iic-i2c-twi-spi-serial-2-6-lcd-1604-module-electronic-building-block-150818#.U8oiDvmSx8E

obrigado e aguandando

Como fizeste a ligação nos pinos de contraste???

SLC > A5
SDA > A4
vcc >5v
Gnd > Gnd

Em princípio, 2 barras pretas, num LCD como esse que tem 4 linhas, quer dizer que não está a ser inicializado em condições. Por isso, eu diria que o problema está no código. O código que está a utilizar é o de algum exemplo que acompanhava o LCD ou tirou de algum sítio?

os codigos sao da net , mas todos que tendei nao ta certo , os de teste "hello word" nao mostra caracteres .

OK. É necessário saber:

  • esquema de ligações (que está na reply #2);
  • código que está a usar;

franciston:
os codigos sao da net , mas todos que tendei nao ta certo , os de teste "hello word" nao mostra caracteres .

Se eu estou a compreender correctamente esta afirmação (isto é se as barras desaparecem mas não é mostrado mais nada) o problema já não é a inicialização, mas sim o contraste, sendo assim, é necessário ajustar o potenciómetro azul que o ecrã tem na parte de trás até se verem os carcateres.

Não respondeste à minha questão...

O cintraste como está ligado? Não tens um potenciómetro de ajuste?

A essa pergunta posso responder eu. Ele está a utilizar um adaptador de I2C/SPI para LCD (vê-se na foto do link que ele enviou). Sendo assim, essa ligação (do potenciómetro) já está feita (e até se pode ver o potenciómetro na imagem).

Ok...

Já alteraste os valores do potenciómetro?

qual é o endereço I2C que estás a usar no teu código?

Que é esse switch na placa? Não será para comutar a comunicação entre I2C e SPI? Tens informação acerca da placa que liga entre o Arduino e o LCD?