Port COM connecting / disconnecting

Hello everybody

I have searched all over the forum and google and couldn't find anything to help me out.

Windows 7 32 bits
Nodemcu ESP12
IDE 1.8.5

Pressing button RESET + FLASH and releasing RESET and after the FLASH, windows (Device manager) shows Nodemcu connected (silicon labs cp210x USB to UART bridge) ready to be programed.

However, once any .ino file is uploaded into Nodemcu, NOTHING is displayed at Windows Device Manger.

  • I have tried unistall drivers and install again but have the same issue.
  • I have tested with a different NOdemcu however present the same issue.
  • I was able to upload blink.ino into Nodemcu and worked perfectly.
  • I was able to upload a webserver.ino into NOdemcu however I am not be able to see any information coming to serial port as I did mention before once any firmware is uploaded into NOdemcu, serial port is not shown into windows Device Manager.

Any info, tip will be very wellcome.

Muganga

How do you know you didn't break it the first time?

If it doesn't show up in Windows Device Manager, you should be getting errors uploading the 2nd time, 3rd time, 4th time, ...

Your post makes no sense.

.

Thank you ieee488..

You absolutly right. It doesnt make any sense. That's why i decided come to this forum and ask for help.

As i did mention before i can upload blink example several time without any error. However, the only way to upload .ino is by pressing Reset + Flash and releasing reset and then flash button. By doing this way it seens the nodemcu enter in upload mode but once the .ino is uploaded, port COM (DRIVE CP210X) is no longer shown at windows device manager.

The pressing Reset + Flash then releasing Reset then Flash is for the ESP8266.

Are you sure you have the right circuitry for the other pins for the ESP8266?

You probably will be better served asking on the NodeMCU.

.

I am using Nodemcu Amica.
I was able to upload Blink example and is working. However once Blink example is uploaded port COM disconnected from windows device manager.

Should I try upgrade/flashing the nodemcu firmware?

Many thanks

It did work!!!

Just flash nodemcu firmware and problem was solved.

Dont need press RST + FLASH then release RST and FLASH.

Many thanks for your help ieee488

mugangamic:
It did work!!!

Good news.

Glad it is working for you.

.