Port COM hardware stop working in laptop help

Hello, I was compiling and something happened halfway, everything stopped working and the COM ports disappeared. I think that the internal chip in the pc stopped working since it does not recognize my SAMD21, Teensy and other boards, I plug them in and nothing, they only receive power, I reset them and nothing, as if they did not exist. USB flash drives work without problem. If I force windows to show the ports, only one appears but disabled. Any idea how to fix it?

So there's nothing wrong with your USB host controller/laptop.

Probably need to reinstall drivers.

Odd question perhaps, but have you tried restarting your laptop? I.e. not putting to sleep, hibernating etc., but a real reboot.

Unplug, remove battery, remove and reinstall drivers and reinstall windows from the same USB.

I found out that if I plug in 3.0 devices they work but 2.0 don't.

Does the board still work on another computer?
Is the problem the same regardless of which USB port you use on the laptop?

nothing less than 3.0 works or is detected, I already tried all the cases in the three ports of the pc. something in some chip stopped working. arduino probe boards with three and nothing, just power

How about this?