Port problem with NodeMCU

I tried serval times loading CP210x USB to UART Bridge VCP Driver (from this link

and CH340X driver from this link

I still can't connect and upload my sketch to NodeMCU

Look forward to any solution to this problem.

Which nodeMCU? Which USB to Serial bridge does it have, CP210x or CH340G? Maybe tell us which operating system you are using.

What errors do you get when trying to upload?

We need a bit more information to be able to help.

Willem.

It has CH340G.
I’m using MacOS 10.13.6
I can’t even see the port in the Arduino tools menu.
This is the error. I can’t upload the picture for some reason.

Please let me know if you need more info.

I am afraid I am not going to be of much help. I am on Windows.

I do not have any problems talking to either the CH340G or the CP2104 - I use both. Not to a nodeMCU but to both an ESP8266 - my own board using a CP2104 - and using a cheap CH340G USB to Serial thingy to talk to both a Nextion display and 328P breadboard circuits.

We now know what you have, and use, so I am sure some Mac user will be along soon to try and help.

Willem

Dear Willem,

I also tried in Windows PC having Windows 10 operating system. Still, the same issue I installed both drivers and when I plug my nodeMCU, I couldn't see any port in device managers.

I also tried with plugging in my Arduino Uno, the moment I plug it show port (as COMx).

I really appreciate if you help me to solve this issue..

Regards,
Muhammad

Hi Muhammed,

Have a look at this thread. If I remember correctly, I followed the suggestions for downloading the driver for the CH340G from it. I do not know where to get information for the Mac.

You do not need the driver for the CP210x series for your board. It is OK to just leave it for possible future use.

Willem.

Hi Willem,

I just figured out what was the issue. It was the USB cable. The moment I changed the cable it starts working.

Thanks for your help.

Regards,
Muhammad

Great - easy solution, once you know about it.

Glad you got it all working - have fun.

Willem.