PORTAIL de MAISON , carte pour le fonctionnement ( ARDUINO NANO )

Merci Denys pour la réponse.
J’aimerais faire un changement sur ce programme mais je n’y arrive pas :frowning:
voir mon problème ici : http://forum.arduino.cc/index.php?topic=404903.0

bonjour

as tu résolu ton problème de temporisation avec les infos que je tes donnée.

DENYS92500@hotmail.com

Bonjour, et merci pour cet excellent travail qui a été fort pédagogique pour moi !

Cependant, il y a a mon sens un petit probleme. En cas de reset (ou coupure elec, ou panne) de l'arduino toute les sorties passent a 0 donc les relay sont alimentés, donc tout le monde recoit du 220V. Les moteurs sont donc alimentés en ouverture ET en femeture en meme temps. Je ne pense pas que les moteur apprecient cela.

La solution que j'ai trouvé est de cabler l'ouverture et la fermeture d'un moteur sur le meme relay et un relay pour envoyer du 220V au commun des relays moteur. Ainsi seul un des cable du moteur peut recevoir du 220v. Et on economise aussi un relay :).

Cordialement

Bonjour ozitoune

Bonne réflexion.

Dans le cas d’une panne électrique EDF les relais seront à l’arrêt, mais il n’y aura pas de courant pour les moteurs.

Dans le cas d’une panne de l’alimentation 5v. Il n’y aura pas de courant sur les moteurs, les relais resteront non alimentaient.

Enfin, dans un tel montage les modifications seront toujours à apporter celons les moteurs utilisés.

S’il y en a qui on modifier ou fait un autre programme de portail, n’hésitez pas à les partager. Le portail ouvre souvent de bonnes idées.

Cordialement

dodotom: Salut

Je suis novice sur arduino j'ai fait le montage avec les memes composants que DENYS92500 mais rien ne se passe cà ne fonctionne pas j'utilise un arduino uno est-ce pour cà? merci pour votre reponse

Bonjour, même souci par ici mais avec la marque Came. Des aides seraient la bienvenue,

bonjour

avez vous des erreurs au moment de la compilation ? le test du montage fonctionne en NANO et MEGA pour les autres carte j'ai pas fait le test. mais la logique veux que cela fonctionne. c'est le même langage sur tous et les librairies son simple..

bonjour deny bravo pour projet je me lance dans arduino donc debutant merci etre indulgent j'ai 2 verrins 12v de portail avec carte hs le probleme c'est que j'ai que 2 fil par verrin alors ci on evite les fin de course et metre un capteur intencité je suis pas obliger de rajouter 2fils? les relays que tu parle son asser puissant pour les verrins ci oui il faut rajouter quoi sur le librairie? merci

bonjour alain33 pour les relais: les contact sont de 10A en 220v. pour les tiens il faudrait connaitre l'intensité des verrins en 12v. mettre des capteurs d'intensité en service dans le programme et tres simple, il te faut mettre des conditions dans les conditions if then. donc, dans un premier temps rajoute la librairie de tes capteur et ensuite fait les bonne conditions dans le programme. cette simple modif va te faire découvrir l'arduino.

merci pour ta reponsse j'attent le materiel pour le montage,mon bras de portail fait 1.2A

Salut DENYS92500

auriez vous des liens pour les différents composants svp ,

je n’arrive pas à mettre la main sur le receiver que vous avez utilisé .

mercii

bonjour

c'est un

set IC 2262/2272 4 CH 315 Mhz Clé Sans Fil Kits De Contrôle À Distance Récepteur module Pour arduino en 433 mhz ou 315mhz, vous trouverez cela partout ( ebay aliexpress etc.)

https://fr.aliexpress.com/store/product/1set-2pcs-2262-2272-Four-Ways-Wireless-Remote-Control-Kit-M4-the-lock-Receiver-with-4/110055_1220887981.html

cordialement

dans ton programme tu n'indiques pas commen tu decodes les signaux de tes emeteurs 433

bonjour

le récepteur 433Mhz donne 0v pour 0 ou 5V pour 1.
et arduino c’est très bien reconnaître une tension 0v ou 5v.
cordialement

Bonjour,

Je suis novice mais je me pause une question. Comment est alimenté l'arduino nano ?

bonjour

avec une alimentation continue. il y a une tonne d'info sur le net.

cordialement

Bonjour cher DENYS92500

Je teste en se moment votre programme pour portail tout fonctionne normalement mais j’aimerai l’adapté à un portail mono battant pour ce faire j’ai modifier votre code en supprimant l’option bouton A et en désactivant tout ce qui concerne le moteur de DROITE, lors de la compilation j’obtient un message d’erreur dans la MISE EN FONCTIONNEMENT DES MOTEURS

Voici ce message
exit status 1
expected unqualified-id before ‘if’

je ne trouve pas la solution pourriez vous m’aidé

un grand merci pour votre partage et pour votre aide
moustique56

portail_modifier_1_moteur.ino (4.97 KB)

bonjour

votre problème viens des parentheses non respecter.

revérifier les parentheses de la fonction IF.

Bonsoir

J'ai bon vérifier les parenthèses je ne voie aucun problème sauf une correction au niveau du signe } avant la fonction bouton C je ne voie rien de spécial

J'aimerai pouvoir supprimé le relais de fermeture et piloté un relais en inverseur pour la fonction ouverture fermeture suivant une temporisation apres ouverture reste 30s ouverte puis se referme

merci encore pour votre aide

moustique56:
J’ai bon vérifier les parenthèses je ne voie aucun problème sauf une correction au niveau du signe } avant la fonction bouton C je ne voie rien de spécial

Bonjour,
L’erreur provient entre autre de la parenthèse ouverte à la ligne 65 => void loop() { …
… et clôturée à la ligne 88 et non pas à la fin (ligne 185).

Il y a en outre pas mal d’erreurs de ce genre dans ton sketch, style “else” sans aucune parenthèse (ligne 70).

En plus:
Tu ne peux pas supprimer les déclarations sans modifier ou supprimer les instructions qui s’y référencent.
p.ex. :
In3 => non déclaré, mais référence à la ligne 123
bloqueB => non déclaré, mais référence à la ligne 134 et 148

… Je pense que le sketch et à revoir dans son ensemble…

l’IDE Arduino propose toutefois des outils pratiques (voir photos)
Marco

Bonjour

Voilà une modification du programme avec un seul vantail.
J’ai juste supprimé le bouton A ‘ deux vantaux).
A testé, car je n’ai plus les moteur.
Tenez-moi au courant
Cordialement

portail_avec_1_vantaux_et_bouton_B.ino (5.55 KB)