Portenta H7 will not boot - orange LED of doom

I have been using Arduino firmware on my Portenta H7 regularly, and I have performed a bootloader update (using the example sketch provided with Arduino IDE) once before. However, after using the same sketch to attempt a bootloader update today, my Portenta will no longer boot. The orange charge LED remains lit (with a slight flicker every ~10 secs), and single- or double-tapping the reset button has no effect.

It will not boot in any mode (DFU, bootloader, normal), and none of my PCs detect that a USB device is even connected. On Linux, there are no messages of any kind from dmesg or udevadm monitor or dfu-util -l when unplugging and replugging the Portenta. On Windows, there are no USB devices detected in Device Manager.

I also regularly use a Segger JLink EDU Mini connected to the 20-pin JTAG header on the Portenta Breakout to debug my Arduino firmware. I thought maybe I could reflash the bootloader using the JLink SWD interface. However, the JLink now also fails to connect to either the Cortex-M7 or Cortex-M4 targets (using Segger tools: JFlash, JLinkGDBServer, and JLinkSTM32).

I'm not sure what else to try. My Portenta H7 is completely unresponsive and unusable now.

Attached are log files showing the output from both JLinkGDBServer and JLinkSTM32.

jlink-gdbserver.log.h (2.4 KB)
jlink-stm32.log.h (985 Bytes)

I had the same Problem and tried to re-burn the bootloader on the Portenta with the Ardiuno IDE and the original ST-LINK V2, but got only a error message.
The I bought the cheaper China Version of ST-LINK V2 from Amazon and tried again, and look, during seconds the Portenta is alive again :slight_smile:
Same setup and JTAG wiring. No Idea why, but this was my solution for this problem.

https://www.amazon.de/dp/B07RKVM7H8/ref=cm_sw_em_r_mt_dp_H5Z0MBTEHYR3DCGGGCMA?_encoding=UTF8&psc=1

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.