Ports COM Windows 10 disparus HELP

Bonjour Je suis sous Windows 10... désolé Windows m'avait inventé deux ports COM qui ne marchaient pas: 6 et 7 Pour l'arduino, j'utilisais 4,5 et 8. Comme par défaut, à chaque téléversement, il utilisait des ports imaginaires, je les ai virés. Il ne l'a pas fait, sauf ce matin... Il a viré 4, 5 et 8 et a gardé les mauvais... Je les ai virés manuellement. Je n'ai plus aucun port COM du coup...

C'est pas possible qu'il soit aussi con??? si???

Une idée de comment remettre des ports COM qui fonctionnent? (à part passer à Linux ^^)

Ça craint ! Peux-tu poster une vue de ton gestionnaire de périphériques ?

J’ai trouvé un truc qui peut t’aider sur un forum anglishe :

Open "Device Manager" (gestionnaire de périphériques, in french)
Select menu "Action" -> "Add legacy hardware", then Click "Next"
Select "Install the hardware that I manually select from a list (Advanced)" -> then click "Next"
Scroll down, then select "Ports (COM & LPT)", then click "Next"
Select "Manufacturer" as your need, (in this case, I'm selecting standard type or default option) then click "Next"
Finish!

Tu peux aussi tester s’il te manque un driver via Mes Drivers

Les boules pin…
J’installais justement legacy et je sais pas m’en servir ^^
J’ai trouvé une carte SD pour essayer liveusb, mais widows ne veut pas la formater en Fat32… sérieux bor
l de m
**e… Du coup je hack une carte SD… Quel progrès chez microchiotte!
J’ai regardé mon compte ce matin pour avoir si je peux l’éclater au marteau comme son prédécesseur, c’est efficace (un problème en moins) et ça défoule. Mais j’ai pas 600 balles è_é Grrrr

La solution du legacy est beaucoup trop complexe, et dès la première étape j'ai rien comme les autres! Faut que je partitionne pour garder mes fichiers et virer windows définitivement de ma vie. Je vais chercher un ISO de Ubuntu qui marche bien. Ca va faire comme se réveiller après 20 ans de coma, j'ai pas fini de chercher comment tout ça fonctionne...

Attention si sous Linux tu fais au hasard en espérant que cela fonctionne tu n'as pas fini de réinstaller.

En général une bonne nuit entre deux actions qui craignent ne peut pas faire de mal.

comme indiqué dans ton autre post, une MAJ windaub annule presque tous les drivers à un moment donné.
encore un autre client hier avec les mêmes soucis.
toutes les versions de nunux fonctionnent bien, il suffit de trouver celle qui te convient le mieux.
si tu réussis a faire redémarrer windaub, attention, à 90% tes fichiers perso se retrouvent dans la corbeille, donc ne surtout pas la vider.