possible networking problem with wifi shield and home network

Hi! I just started using my wifi shield wity my uno, and I ran into a problem that I don't understand. I loaded up the "simple web server" and ran it. Watching the terminal, I could see that the wifi shield connected to my network, and was assigned an ip address. Now, I was supposed to be able to type that ip into my browser to see the simple web page. When I typed in the ip, I got an error " page not available"
I tried connecting with multiple devices and multiple browsers. No luck.
Any ideas? My wifi router is a wrt-54g2 router, running the stock firmware. Is there a setting I should change on it?

I have got the exact same problem. The WiFi shield connects to my WPA2 protected network, gets an IP address which I can ping but if I do a port scan there are no open ports (using the SimpleWebServerWiFi example sketch).

Have you upgraded the firmware? Here is a test sketch to determine the firmware version. If it reports 1.0.0, it needs to be upgraded. If it reports 1.1.0, it is current.

#include <WiFi.h>
#include <SPI.h>

void setup() {
  Serial.begin(9600); 

  // disable SD SPI
  pinMode(4,OUTPUT);
  digitalWrite(4,HIGH);

  // check for the presence of the shield:
  if (WiFi.status() == WL_NO_SHIELD) {
    Serial.println("WiFi shield not present"); 
    // don't continue:
    while(true);
  } 

  // check firmware version
  Serial.print(F("Firmware version: "));
  Serial.println(WiFi.firmwareVersion());.
}

void loop() {
}

Here is a link to the official instructions for upgrading, but you may be better off searching to forum for better ways.
http://arduino.cc/en/Hacking/WiFiShieldFirmwareUpgrading

My WiFi Shield reported version 1.0.0 so I went through the firmware upgrade process. With the sketch it is still reporting version 1.0.0. If I connect through the serial interface to the WiFi Shield it should normally also report the version number. However, all I get is

$ Arduino Wifi Startup... [Sat Jan 19 09:44:18 2013]
Connect to network...OK
link up, connected to "mySSID"
requesting dhcp ... OK
bound to 192.168.1.93

. Is something wrong with my WiFi Shield?

If the firmware is still showing 1.0.0, then the upgrade did not work.