Potentiometer on a Servo

Hi, everyone i'm new here. I have been working with Arduino for a few months now. I have some basic electronics knowlege.
I am trying to control a servo motor with a potentiometer, which I have managed to do, however sometimes the servo will go out of control, back and forth. I managed to isolate the problem down to the potemtiometer and the wires connecting to it. If I twist the wires to a certain position there is no erratic behaviour, also if I squeeze the pot or the 3 wires leading to it really hard it works fine. I have placed a cable tie tightly around the wires on the pot contacts, and it is working quite well. It is like there is some interferance coming from somewhere. All the connections are soldered well, and I have tried different pots with the same result, so it cant be a loose contact.

I dont understand what is going on???


Please post your code and a schematic if possible,

Here is the code:

#include <Servo.h> 
Servo myservo;  
int potpin = 0; 
int val;    
void setup() 
void loop() 
  val = analogRead(potpin);            
  val = map(val, 0, 1023, 0, 179);     
} [code]
 Everything is soldered and heat shrinked.




Is the wire solid or stranded?
How long is the wire?

Code looks good. You might do multiple readings from the pot and average them to remove some noise of the ADC

void loop() 
  val = 0;
  for (int i=0; i< 4; i++) val += analogRead(potpin);
  val = val/4;          
  val = map(val, 0, 1023, 0, 179);

Some questions:
How about the wires to the servo?
TYpe of Servo?
how much milli amps does it draw?
What powersupply are you using?

It is stranded copper wire. CAT5 Ethernet cable. It is about 500mm long. It plugs into a socket soldered onto a arduino prototype board, which then leads to digital pin 9 and analog pin 0. The setup works fine, with the cable ties as in the picture, but it becomes erratic if they are removed.

The servo is a HITEC HS-300. Im not sure how much current it draws. It is out of an old model aeroplane I had. Im using a 9 volt 800mA power supply. Either with the 9V or the USB cable I get the same problem.

Possible causes: bad solder joints, insulation cut to cause shorts between wires, broken wires.