Power to other components causes arduino serial communcation to stop working


I have some components and sensors wired point to point on a board bought from radioshack. They are powered by a power supply right now and the sensors have outputs that connect to the analog pins on the arduino mega 2560. The serial communication works perfectly when the power supply is not on but when I flip the power switch on, the data on the serial port is a bunch of gibberish. When I turn the power supply off, the serial port starts to read normally again. I have fought and fought and fought with this issue and can't for the life of me figure out what is going on. I have tried to disable Auto-reset (didn't work), I've tried holding down reset, removing and replacing usb cable, and then release when I upload and that doesn't work. Sometimes the L light will flash or stay on, sometimes the TX will flash, and rarely will RX flash. I know of no incident where I would have fried any pins or anything of that nature. Any thoughts would be GREATLY appreciated!

Just did the loop back test and that works. Not sure if this information helps but just wanted to add it.

Schematic. Or at the very least a clear, focused picture.

Also a list of what "components" means.

Thanks for the reply but I fixed it. I did a test where I disconnected everything from the arduino board then connected Reset to GND and TX to RX (to do the Loop back test). When I removed both of those jumper wires, it seems as though the problem corrected itself. By components I meant resistors, capacitors, wires, etc. Thanks again.