[Pro Micro ATmega32U4 5V 16MHz] Programs aren't uploaded, I guess?

Hi!

I've ordered the Pro Micro ATmega32U4 5V 16MHz
http://www.amazon.com/Generic-Atmega32u4-Replace-Atmega328-Arduino/dp/B00QFY3KG6/ref=pd_sxp_redirect

It seems to be the same product as:

I opened the Blink Example project in the Arduino IDE 2:1.0.5+ (the current Ubuntu Software Center version) and changed the Board to Arduino Micro. Then I clicked the upload button and the IDE finished with 'Done Uploading'. I don't get any error in the terminal as well.

However, the project isn't uploaded or at least something doesn't work. The RX and TX leds don't blink during the upload. Any led blinks. The power led is constantly glowing also.

From time to time, the RX led blinks 1-2 times if the Arduino is connected via usb.

I have

  • tested two micro-controllers, both with the same behavior.
  • set the board to 'SparkFun Pro Micro 5V' as well. (https://github.com/sparkfun/SF32u4_boards/archive/master.zip)
  • used other USB ports.
  • changed the programmer to every possible setting. All are finishing with the successful message 'Done Uploading'.
  • changed the led and led pin.
  • burning the bootloader, but each 'Programmer' fails to do so. No led is blinking as well.

Please help :slight_smile:

The blink example blinks the LED connected to pin 13. You don't have a pin 13 do you?
You can change the blink sketch to blink some other pin. Blink a pin you have an external LED and resistor connected to, or the built-in LED on that board is pin 17.

Thanks for your reply! :slight_smile:

I've already tried other pins. No luck. :frowning:
I didn't know about the build in led, but unfortunately, it also doesn't blink.

I also changed the led itself and used a multimeter to measure the voltage.

It’sa me again! :wink:

I bought another pair from a different manufacturer. Same problem.
Aren’t they programmable over USB? What am I missing?

I don't know. Those boards are small Leonardos and they are a little more difficult to troubleshoot because the loopback test does not work with them.
I suggest going over the hookup guide, especially the drivers part of it. On Mac these things just work without any driver details. But on Windows I see the guide has you doing some stuff to get the driver working.

https://learn.sparkfun.com/tutorials/pro-micro--fio-v3-hookup-guide

Thanks for your reply and help dmjlambert! +1 karma. The link indirectly helped me solving the problem :slight_smile:

I’m so stupid. :frowning: >:(
The Ubuntu Software Center version of the Arduino IDE is 2:1.0.5+
I misread the 2 as version 2 and thought 2 > 1.5. However, the version is 1.0.5. After installing the current IDE version 1.6.5 from the arduino homepage, everything worked as described in the tutorial.

So software center is the culprit. That is an old version. I wonder what the "2:" and the "+" mean. In Linux I do things the manual way, downloading source and compiling or downloading tar file and untaring instead of using a package installer. So that is why I didn't notice a problem with mine. I know Ubuntu is popular, but I like CentOS because of my experience with Red Hat at work.