Pro Mini COM4 Busy

Hey guys - extremely annoyed at this.

I'm trying to push a sketch to the pro mini but it's saying COM4 is busy. I've tried changing the COM on my computer. I've tried holding the reset button before I upload and releasing at the proper time. I've tried uninstalling the driver then reinstalling. I've tried restarting after executing multiple of these actions.

It was working fine until recently. I connected an oLED screen and ran the 128x32 i2C example from SSD1306 library. It ran well and the sketch loaded to the board. If I plug the oLED in now it continues to run the example script. I can't access reset or restore the board.

I've looked around at many forums and tried (I think) everything they've suggested.

OS: Win10

The COM port can only be open in one program at a time. If you have an application other than the Arduino IDE/arduino-cli/Arduino Web Editor that is accessing that COM port, you'll need to either make that application close the port, or else close the application.

If you don't have another program using the port, try restarting your computer. Sometimes a glitch will cause COM ports to get stuck in an unusable state and restarting the computer will fix this.