Pro Mini, no communication

Tried uploading a program to a Pro Mini 3.3v with a 328. Got the following error;

avrdude: stk500_getsync(): not in sync: resp=0x00 avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

I have three pro mini's, brand new, and get the exact same results on all three of them.

I'm using the Sparkfun FTDI breakout board. When I plug it in the green LED on the Pro flashes once, the TX and RX lights on the BOB flash once, and the red LED (power, right?) on the Pro stays lit. Nothing shows up in Device Manager when plugged in, the ports don't change. It's almost as if it doesn't exist. Double checked voltage just to be sure, it's only getting 3.3v, so I can't imagine I fried anything. I have an Uno which programs just fine, no problems at all, so it's not the drivers, right?

Any help at all would be appreciated.


a usb device doesnt show up in device manager?

shippo0708: a usb device doesnt show up in device manager?

With the Pro Mini I get nothing under ports or USB devices. With the Uno, yes I get it to show up under Ports.


When you connect the PC to just the FTDI board, does the COM port show up in the IDE? Does it flash when you write stuff in the Serial Monitor?

Close the Serial Monitor, connect the Pro-Mini and check it flashes. Now re-open the Serial Monitor window. Does the Pro Mini flash again?

If not you may need to install the FTDI drivers, as per The FTDI driver isn't the same as the Uno one.

I am having the same issue with my mini pro 328 3.3v

I first tried on my PC ( vista) and it said COM port already in use even when it wasnt.

So I tried on my lap top. That error went away but now I get the sync error. I have checked that I am using the correct setting under tools/board. The COM port seems to be correct and I have ticked "Set RTS on close" in device manager advanced settings for com port. baud rate of com port is 9600.

Any suggestions?

Also I get no green LED ( pin 13) on my mini pro board at any time but I do get the red power LED when plugged into FTDI 3.3v cable.

EDIT: same result if I remove board from cable. So I guess the computer recognises the cable is there but cant see the board.

This is a long shot - But have you turned all Bluetooth programs/hardware off?

This has traditionally caused problems with Arduino software.