Pro Mini not in sync?

I've got my Pro Mini 5v/16MHz hooked up to my computer through an Arduino USB board... (Like here: ...and when I try to upload to it, I get an error... avrdude: stk500_getsync(): not in sync: resp=0x00 avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51 ...and I can't seem to get rid of it.

I've tried selecting the Arduino Duemilanove w/ 328, Pro Mini w/ 128, and Pro Mini w/ 328 and none seem to work.

I have a Pro Mini with an ATmega328 and it's 16MHz/5V.

What am I doing wrong? I've checked my connections and everything. I really don't want to have to buy the FTDI breakout connector for this, because I already have my pro mini soldered up inside a controller and the 5 pins for uploading are brought to a connector on the bottom instead.

Will a lengthy cable give me this error? I've got about 5-6" between both Arduinos.

Try the lilypad with 328. For my first few attempts, this was the only thing I could get to work with the 5V pro mini.

Still not working. Maybe I should just buy an FTDI breakout board for it? What if it still doesn't work when I get that?

You should be using the RX and TX, but connect them directly to eachother, RX on the Arduino goes to the RX on the Mini, and vice versa, and also make sure you connect the grounds and make sure the Mini has 5v as well.

But it should be the Pro-mini with the 328..

Have you tried resetting as you're uploading? What I like to do is hit upload, hold down reset until you see the TX or RX light, then let go.

There's no need for the FTDI breakout board if you have the Arduino like you do, it's got to be some wiring errors. I use my Board to program my other chips, never used a mini, but 168, 328, and atmega8, all with no problems.

I'll double and triple check my wiring, but it looks like it's fine. Maybe I need to shorten the wires.

I've got; RX - RX TX - TX GND -GND 5v - VCC RST - GRN

Does it matter that I'm using the TX/RX pins on the side of the mini and not the ones on the bottom? (Bottom being the side there a 6 pin head would be soldered for the FTDI breakout)

EDIT: I got it. I had the wiring to the connector messed up. I never cut the traces on the connector, and I had the whole controller grounded. My RX was connecting to GND somewhere along the lines. I got it fixed.