Problem because I don't work behind a proxy

Hello,

at work I am workind behind a proxy, so i configured my Network Manager to use a proxy, if I use a specific wifi. The Proxy Server at work is called arktur.

Now I installed arduino IDE, and it can’t connect to the Internet, because I am at home right now, and arduino wants to use the Proxy.

Error downloading http://arduino.esp8266.com/stable/package_esp8266com_index.json
Error downloading https://downloads.arduino.cc/packages/package_index.json
 Error downloading https://github.com/esp8266/Arduino/releases/download/2.4.1/esp8266-2.4.1.zip
java.lang.RuntimeException: java.lang.Exception: Error downloading https://github.com/esp8266/Arduino/releases/download/2.4.1/esp8266-2.4.1.zip
	at cc.arduino.contributions.packages.ui.ContributionManagerUI.lambda$onInstallPressed$2(ContributionManagerUI.java:175)
	at java.lang.Thread.run(Thread.java:748)
Caused by: java.lang.Exception: Error downloading https://github.com/esp8266/Arduino/releases/download/2.4.1/esp8266-2.4.1.zip
	at cc.arduino.contributions.DownloadableContributionsDownloader.download(DownloadableContributionsDownloader.java:144)
	at cc.arduino.contributions.DownloadableContributionsDownloader.download(DownloadableContributionsDownloader.java:78)
	at cc.arduino.contributions.DownloadableContributionsDownloader.download(DownloadableContributionsDownloader.java:60)
	at cc.arduino.contributions.packages.ContributionInstaller.install(ContributionInstaller.java:105)
	at cc.arduino.contributions.packages.ui.ContributionManagerUI.lambda$onInstallPressed$2(ContributionManagerUI.java:172)
	... 1 more
Caused by: java.net.SocketException: Can't connect to SOCKS proxy:arktur
	at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:428)
	at java.net.Socket.connect(Socket.java:589)
	at sun.security.ssl.SSLSocketImpl.connect(SSLSocketImpl.java:666)
	at sun.net.NetworkClient.doConnect(NetworkClient.java:175)
	at sun.net.www.http.HttpClient.openServer(HttpClient.java:463)
	at sun.net.www.http.HttpClient.openServer(HttpClient.java:558)
	at sun.net.www.protocol.https.HttpsClient.<init>(HttpsClient.java:264)
	at sun.net.www.protocol.https.HttpsClient.New(HttpsClient.java:367)
	at sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.getNewHttpClient(AbstractDelegateHttpsURLConnection.java:191)
	at sun.net.www.protocol.http.HttpURLConnection.plainConnect0(HttpURLConnection.java:1199)
	at sun.net.www.protocol.http.HttpURLConnection.plainConnect(HttpURLConnection.java:1050)
	at sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.connect(AbstractDelegateHttpsURLConnection.java:177)
	at sun.net.www.protocol.https.HttpsURLConnectionImpl.connect(HttpsURLConnectionImpl.java:162)
	at cc.arduino.utils.network.HttpConnectionManager.makeConnection(HttpConnectionManager.java:150)
	at cc.arduino.utils.network.HttpConnectionManager.makeConnection(HttpConnectionManager.java:106)
	at cc.arduino.utils.network.FileDownloader.openConnectionAndFillTheFile(FileDownloader.java:234)
	at cc.arduino.utils.network.FileDownloader.downloadFile(FileDownloader.java:182)
	at cc.arduino.utils.network.FileDownloader.download(FileDownloader.java:129)
	at cc.arduino.contributions.DownloadableContributionsDownloader.download(DownloadableContributionsDownloader.java:142)
	... 5 more

OK, somehow Arduino got wrong Proxy Information. I never use arduino at my workplace, therefore I opened
File → Preferences, then opened the tab “Network”. I choosed “No proxy”

OK, same error, didn’t help.

Time to check the preference-file:

cat /home/mischka/.arduino15/preferences.txt | grep proxy
proxy.manual.hostname=
proxy.manual.password=
proxy.manual.port=
proxy.manual.type=HTTP
proxy.manual.username=
proxy.pac.url=
proxy.type=none

proxy.type=none, so why does it want to use any proxy? I restarted arduino several times, I even restartet my PC. Did not help.

BTW: Just in Case it is needed, the full preferences.txt is attached

preferences.txt (7.23 KB)

Your error seems related to a particular package for the ESP’s
This is not uncommon for the ESP sites to have glitches.

You can either wait until it is resolved or choose an alternate ESP site.
You might also want to change the HTTP to HTTPS in the preferences for additional boards.

Another work around is to sometimes double up the same additional boards line.
Not sure if that particular issue has been resolved yet.

Bob.

See: JDK-8144008 : Setting NO_PROXY on HTTP URL connections does not stop proxying

Bug is in the java runtime, versions:

JDK 8u66 - Fail
JDK 8u72 - Fail
JDK 9ea b85 - Fail