Problem bei Stromversorgung v. Mega, ESP, OLED und SIM-KNX

Hallo Forengemeinde, ich habe eine Frage bei meinem Projekt wo ich mir absolut keinen Rat mehr weiss und deshalb hier um Hilfe fragen möchte:

Ich betreibe einen Arduino MEGA der seriell mit ESP kommuniziert und ebenfalls mit einem OLED Display und einem SIM-KNX kommuniziert. Die technische Seite funktioniert alles einwandfrei.... zumindest solange ich die Spannungsversorgung realisiere indem ich beide Controller, also Arduino und ESP über ihre USB Schnittstellen mit dem PC verbinde, das war bis jetzt immer der Fall da ich ja noch im Programmierstadium war.

Nun aber habe ich ein 9V Netzteil (1A) an den Arduino angeschlossen und alle anderen Verbraucher an die 3,3V Ausgangsklemme des Arduino, bzw. an den GND Anschluss gelegt.

Nun wird zwar das Display noch angeschlossen, aber der ESP "fährt nichtmehr hoch" ... ich kann mir das nicht erklären da das Netzteil mit 1A weit mehr Leistung bereitstellen kann als meine Schaltung benötigt (habe ich gemessen, SIM-KNX benötigt 20mA)

Gibt es hier noch irgendeine Tücke das über die 3,3V Buchse des Arduino evtl. ein niedrigerer Strom als der maximale des Netzteils fließen darf ? Bisher habe ich alles immer getrennt über USB betrieben (mit Erfolg) wie bekomme ich es jetzt hin die Schaltung mit dem 9V Netzteil zu versorgen?

Es wäre schön und nett wenn mir jemand hier etwas Licht ins Dunkle bringen könnte...

Vielen Dank und freundlichen Gruß, Tobi

Moin,

hatte mit dem ESP ähnliche Probleme. Bei mir hat ein Kondensator zwischen VCC und GND des ESPs zum Erfolg geführt. Habe 0,1µF gewählt wenn ich das noch richtig weiß... Vielleicht probierst du das mal?

Die 3,3V des Mega reichen nicht aus um den ESP zu versorgen! Du musst dir eine separate Spannungsversorgung aufbauen, einmal für den Mega und eimal für den ESP

@Scherheinz: Wie meinst du das genau? Wieso hat es dann bei Nanunan funktioniert?

Scherheinz was würdest du empfehlen das es geht?

Scherheinz: Du musst dir eine separate Spannungsversorgung aufbauen, einmal für den Mega und eimal für den ESP

Also z.B. mit einem 3.3V Festspannungsregler an der Arduino Buchse die Netzteilspannung abgreifen und dann an den ESP. Das dürfte doch gehen oder?

Ja z.B. An dem 3,3V Pin des Mega kannst du maximal 50mA abgreifen. Der ESP braucht zwischen 10 und 200mA, kommt immer darauf an was er gerade macht. Deshalb hat es bei Nanunan zufällig funktioniert, aber auch nur zum Test denn auf Dauer reicht es einfach nicht aus.

Gruß

Und nanunan hat nicht beschrieben, ob er die 3,3 Volt auch vom Arduino Pin nimmt.