Problem burning Bootloader to Arduino Robot Control Board using Arduino as ISP

So my Arduino Robot Control Board stopped accepting sketches through the serial port so after reading countless forums I figured I should reflash my chip (ATmega32U4) with a new bootloader. Using my Arduino UNO as an ISP I attempted to burn a bootloader through the Arduino IDE. But I kept getting the "Yikes! Invalid device signature. Double check connections and try again, or use -F to override this check." error. So after more researching I found this comment telling me how to upload a program straight to the chip, bypassing the bootloader, and they said it worked for their Arduino Robot Control Board. So I tried it with the "Beep" sketch and lo and behold the robot started beeping.
DISCLAIMER: The events proceeding occurred after 3 a.m. so the order of the events are ambiguous and the fine details are cloudy
So then I (stupidly) tried uploading a more complex sketch to it via the IDE, forgetting that I overwrote the bootloader, and of course that didn't work. I remembered that I had to do it the programmer way and tried uploading it through avrdude, but that didn't work. I also read that to program to the robot chip the TFT screeen must be removed so I removed that. Then I tried using my newfound knowledge of avrdude to burn a bootloader to the chip. So I copied the code outputted by the Arduino IDE bootloader uploader when verbose output is enabled, which is
avrdude -C"C:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf" -v -patmega32u4 -cstk500v1 -PCOM6 -b19200 -e -Ulock:w:0x3F:m -Uefuse:w:0xcb:m -Uhfuse:w:0xd8:m -Ulfuse:w:0xff:m
and added the -F argument to avoid getting the invalid device signature error from earlier. After running it I noticed in the log it said

avrdude: verification error, first mismatch at byte 0x0000
         0x00 != 0x3f
avrdude: verification error; content mismatch

avrdude: safemode: lfuse reads as 0
avrdude: safemode: hfuse reads as 0
avrdude: safemode: efuse reads as 0
avrdude: safemode: Fuses OK (H:00, E:00, L:00)

avrdude done.  Thank you.

The same device signature error that got bypassed was also in there. I have now noticed that my computer does not even recognize my Robot Control Board anymore, nothing in device manager, Arduino IDE, nor the Windows device detected noise. I have also tried using Nick Gammon's Atmega_Board_Programmer to only get the error "Failed to enter programming mode. Double-check wiring!" Then I read that disabling the Arduino Uno's auto-reset feature can solve these errors. Methods of doing were connecting a capacitor greater than 10uf between the RESET pin and ground and/or connecting a ~120 ohm resistor between RESET and 5v. So I went back and retried all my approaches with just the capacitor, just the resistor, and both the capacitor and resistor. None of them worked.

I'm at my wits end with the board. I've read of many people with this board getting all these same errors but no one seems to fully solve the problem. I've never going to mess with one of these boards again, way too overpriced and buggy. I'm just hoping I didn't permanently mess up any of the chips on it.

Next time I suggest you post before you reflash the bootloader. Bootloaders do not normally just disappear.

Judging by the response you got above there is no response from the chip.

Can you run my "chip detector" sketch? Gammon Forum : Electronics : Microprocessors : Sketch to detect Atmega chip types

Then I read that disabling the Arduino Uno's auto-reset feature can solve these errors.

That will have no effect on my sketches, as they use ICSP, not serial. Forget the capacitor, the resistor, all that. Just get the chip detector to recognize the chip. Until you do that, there is no point in proceeding.

As to your actual problem (not the problem you caused by reflashing the bootloader) - did you do anything of interest before it all failed? Perhaps connected the battery backwards, that sort of thing?

If you mean what caused the problem in the very beginning, I was making a wall detecting sketch for the robot and to debug it I had the sketch print the values of the distance sensors to the TFT screen. But I must've made a mistake because the screen kept flashing, and I tried changing the sketch and uploading it and it would get stuck on "Uploading..." forever.

I'll try your chip detector.

Thats the Atmega32u4 chip isn't it? You normally have to press and release the reset button at the moment you start uploading.

I'm getting the same error as the Board Programmer

Attempting to enter ICSP programming mode ......................................................
Failed to enter programming mode. Double-check wiring!
Programming mode off.

I'm trying to upload pictures of my wiring but they're taking forever.


I'm trying to upload pictures of my wiring but they're taking forever.

Not too surprised at half a megabyte each. Phew! Think of the time it takes us to download them! And the load on the server. How about a little resizing first, next time?


Assuming you wired it correctly (and it isn't that easy to see because some wires block the view of others) you may have a damaged chip.

Shoot sorry about that, I didn't think about that. But it's not on the arduino servers, it's hosted on imgur.