Problem compiling/installation

Hi,

I’m running Kubuntu Hardy Heron on a zd8000 laptop, Pentium 4, at about 3 GHZ; I installed JRE 6 and the support files for C, per directions. I Could not run Arduino, so I tried to compile it from the TAR file.
When I executed ./configure, I got an error message: “Compiler cannot create executables”. It asked me to look at the log file: (sorry for length, but I’m not sure what part of it, if any, is OK to omit for this question)
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

It was created by avrdude configure 5.4-arduino, which was
generated by GNU Autoconf 2.59. Invocation command line was

$ /home/doctorles/arduino2/avrdude-5.4-arduino-src/configure

---------

Platform.

---------

hostname = doctorles-laptop
uname -m = i686
uname -r = 2.6.24-16-generic
uname -s = Linux
uname -v = #1 SMP Thu Apr 10 13:23:42 UTC 2008

/usr/bin/uname -p = unknown
/bin/uname -X = unknown

/bin/arch = unknown
/usr/bin/arch -k = unknown
/usr/convex/getsysinfo = unknown
hostinfo = unknown
/bin/machine = unknown
/usr/bin/oslevel = unknown
/bin/universe = unknown

PATH: /usr/local/sbin
PATH: /usr/local/bin
PATH: /usr/sbin
PATH: /usr/bin
PATH: /sbin
PATH: /bin
PATH: /usr/games

-----------

Core tests.

-----------

configure:1354: checking build system type
configure:1372: result: i686-pc-linux-gnulibc1
configure:1380: checking host system type
configure:1394: result: i686-pc-linux-gnulibc1
configure:1402: checking target system type
configure:1416: result: i686-pc-linux-gnulibc1
configure:1446: checking for a BSD-compatible install
configure:1501: result: /usr/bin/install -c
configure:1512: checking whether build environment is sane
configure:1555: result: yes
configure:1620: checking for gawk
configure:1649: result: no
configure:1620: checking for mawk
configure:1636: found /usr/bin/mawk
configure:1646: result: mawk
configure:1656: checking whether make sets $(MAKE)
configure:1676: result: yes
configure:1894: checking for gcc
configure:1910: found /usr/bin/gcc
configure:1920: result: gcc
configure:2164: checking for C compiler version
configure:2167: gcc --version </dev/null >&5
gcc (GCC) 4.2.3 (Ubuntu 4.2.3-2ubuntu7)
Copyright (C) 2007 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

configure:2170: $? = 0
configure:2172: gcc -v </dev/null >&5
Using built-in specs.
Target: i486-linux-gnu
Configured with: …/src/configure -v --enable-languages=c,c++,fortran,objc,obj-c++,treelang --prefix=/usr --enable-shared --with-system-zlib --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --enable-nls --with-gxx-include-dir=/usr/include/c++/4.2 --program-suffix=-4.2 --enable-clocale=gnu --enable-libstdcxx-debug --enable-objc-gc --enable-mpfr --enable-targets=all --enable-checking=release --build=i486-linux-gnu --host=i486-linux-gnu --target=i486-linux-gnu
Thread model: posix
gcc version 4.2.3 (Ubuntu 4.2.3-2ubuntu7)
configure:2175: $? = 0
configure:2177: gcc -V </dev/null >&5
gcc: ‘-V’ option must have argument
configure:2180: $? = 1
configure:2203: checking for C compiler default output file name
configure:2206: gcc conftest.c >&5
/usr/bin/ld: crt1.o: No such file: No such file or directory
collect2: ld returned 1 exit status
configure:2209: $? = 1
configure: failed program was:
| /* confdefs.h. /
|
| #define PACKAGE_NAME “avrdude”
| #define PACKAGE_TARNAME “avrdude”
| #define PACKAGE_VERSION “5.4-arduino”
| #define PACKAGE_STRING “avrdude 5.4-arduino”
| #define PACKAGE_BUGREPORT “avrdude-dev@nongnu.org
| #define PACKAGE “avrdude”
| #define VERSION “5.4-arduino”
| /
end confdefs.h. */
|
| int
| main ()
| {
|
| ;
| return 0;
| }
configure:2248: error: C compiler cannot create executables
See `config.log’ for more details.

----------------

Cache variables.

----------------

ac_cv_build=i686-pc-linux-gnulibc1
ac_cv_build_alias=i686-pc-linux-gnulibc1
ac_cv_env_CC_set=
ac_cv_env_CC_value=
ac_cv_env_CFLAGS_set=
ac_cv_env_CFLAGS_value=
ac_cv_env_CPPFLAGS_set=
ac_cv_env_CPPFLAGS_value=
ac_cv_env_CPP_set=
ac_cv_env_CPP_value=
ac_cv_env_LDFLAGS_set=
ac_cv_env_LDFLAGS_value=
ac_cv_env_build_alias_set=
ac_cv_env_build_alias_value=
ac_cv_env_host_alias_set=
ac_cv_env_host_alias_value=
ac_cv_env_target_alias_set=
ac_cv_env_target_alias_value=
ac_cv_host=i686-pc-linux-gnulibc1
ac_cv_host_alias=i686-pc-linux-gnulibc1
ac_cv_path_install=’/usr/bin/install -c’
ac_cv_prog_AWK=mawk
ac_cv_prog_ac_ct_CC=gcc
ac_cv_prog_make_make_set=yes
ac_cv_target=i686-pc-linux-gnulibc1
ac_cv_target_alias=i686-pc-linux-gnulibc1

-----------------

Output variables.

-----------------

ACLOCAL=’${SHELL} /home/doctorles/arduino2/avrdude-5.4-arduino-src/missing --run aclocal-1.9’
AMDEPBACKSLASH=’’
AMDEP_FALSE=’’
AMDEP_TRUE=’’
AMTAR=’${SHELL} /home/doctorles/arduino2/avrdude-5.4-arduino-src/missing --run tar’
AUTOCONF=’${SHELL} /home/doctorles/arduino2/avrdude-5.4-arduino-src/missing --run autoconf’
AUTOHEADER=’${SHELL} /home/doctorles/arduino2/avrdude-5.4-arduino-src/missing --run autoheader’
AUTOMAKE=’${SHELL} /home/doctorles/arduino2/avrdude-5.4-arduino-src/missing --run automake-1.9’
AWK=‘mawk’
CC=‘gcc’
CCDEPMODE=’’
CFLAGS=’’
CPP=’’
CPPFLAGS=’’
CYGPATH_W=‘echo’
DEFAULT_PAR_P

Maybe a stupid question, but are you sure you have r+w access to the directory you're trying to build from ? It's usually not a good idea to start a configure as root, but maybe you can try it.

What error did you get when you tried to run Arduino? It's likely that you don't need to build the whole source tree, but probably only a particular library.

Thanks to both responders.

I get no error message b/c I cannot get Arduino to start at all. There is no detectable change when I try to run the script. I assume I shouldn't expect to see one since the compilation/installation process stalled in the ./configure mode.

I have stared at the log file a long while, trying to decipher it with my limited knowledge regarding these things. I note that the config app was unable to find a certain directory or file, including: usr/bin/ld. So I'm wondering if I needed to use the "--prefix" option somehow?

The only file I could find that helped with the installation process was "INSTALL", but it did not address my problem, nor did it indicate where I should extract the TAR files to. So I extracted them to a desktop folder I made for this purpose. I'm wondering if I needed to send it elsewhere?

I can locate /usr/avr folders, and the /usr/avr directory includes "bin", "include", and "lib" sub-directories. Also, my usr/bin directory contains a number, perhaps 20, files that have "avr" in their titles. But, there are no avr-related files in my /usr/local directory or subdirectories, even though some avrdude documentation said that this is the "default" installation directory--at least on some systems.

Please note, I executed the ./configure process under sudo.

Any other clues? Maybe there is an installation help file at the Arduino site that I overlooked, but I followed the directions given for Ubuntu 6.06, because I could not find any for Hard Heron specifically.

Finally, I'm also wondering about the version of Sun Java I installed, which is 6, vs. version 5 as indicated in the instructions? I don't think that should be an issue but, hey, what ev'.

Thanks

Les

If you download the Arduino software: http://www.arduino.cc/en/Guide/HomePage, and run: ./arduino from a terminal in the directory you unzip the software to, what message do you get?

The thing you're trying to ./configure and compile is avrdude, used by the Arduino software to upload programs to the board. There's a precompiled version that comes with the Arduino software, so you might not need to build it yourself.

First, thanks for staying with me on this; I really have struggled with it.

I get:


doctorles@doctorles-laptop:~/arduino/arduino-0011$ ./arduino
Experimental: JNI_OnLoad called.
Stable Library

Native lib Version = RXTX-2.1-7
Java lib Version = RXTX-2.1-7

(:6768): Gtk-WARNING **: Attempting to add a widget with type GtkButton to a GtkComboBoxEntry (need an instance of GtkEntry or of a subclass)

(:6768): Gtk-CRITICAL **: gtk_widget_realize: assertion `GTK_WIDGET_ANCHORED (widget) || GTK_IS_INVISIBLE (widget)’ failed

In file included from /home/doctorles/arduino/arduino-0011/hardware/cores/arduino/WProgram.h:6,
from Stepper.cpp:48:
/usr/lib/gcc/avr/4.2.2/…/…/…/…/avr/include/avr/signal.h:36:2: warning: #warning “This header file is obsolete. Use <avr/interrupt.h>.”
In file included from utility/twi.c:25:
/usr/lib/gcc/avr/4.2.2/…/…/…/…/avr/include/avr/signal.h:36:2: warning: #warning “This header file is obsolete. Use <avr/interrupt.h>.”


Then Arduino does start; it won’t from the gui, however.

At the bottom of the screen is a lot of red error text which I cannot seem to copy/paste here,
but some of it says (paraphrasing): “warning, this header file is obsolete, use avr/interrupt.h”
etc., etc.

OK, this is weird, but I think I'm happy with it--so far.

Since running the "./arduino as $ in a terminal window it gave the messages I just posted, but I now plugged in my Boarduino to the USB port, /dev/ttyUSBO and the damned thing let me connect to it and even upload a test sketch, "blinky no delay", and it runs!!!

I have a hunch that all isn't Kosher just yet, but I'm totally jazzed after fighting with this thing all weekend and several nights last week!

I have to make some progress on my project of running an IR remote temp sensor. I got a lead on some sensors from a firm in the Netherlands; they make the widget that goes into hand held remote sensors.

Thanks for your help; I can still use some input, I'm sure.

Regards,

Les