Problem connecting to cloud with MKRWiFi1010

Hi, I have an MKR1010 and have trouble connecting to the cloud. I'm stuck at this step:

So I went into the online IDE and managed to get the following from the monitor:

[ 6101 ] WiFi.status(): 0
[ 6101 ] Current WiFi Firmware: 1.0.0
[ 6102 ] Latest WiFi Firmware: 1.2.1
[ 6102 ] Please update to the latest version for best performance.
[ 11102 ] Connecting to "WiFi-2.4-B777"
[ 16344 ] Connected to "WiFi-2.4-B777"
[ 16344 ] Connecting to Arduino IoT Cloud...
[ 16576 ] Bogus NTP time from API, fallback to UDP method
[ 18452 ] Bogus NTP time from API, fallback to UDP method
[ 20307 ] Bogus NTP time from API, fallback to UDP method

I tried updating the firmware. Went to WifiNina > Tools > FirmwareUpdater - but when I upload this sketch, not much happens. I can't see anything in the monitor at all even though it tells me it got uploaded successfully, is it normal that it initializes with Serial.begin(1000000); ? Because I don't see that number in the baud settings for the monitor. There's an orange LED blinking on my board right now - CHRG, but I'm guessing its not related.

I also tried to see if I had firewall settings on my router incase that was the problem. But I wasn't sure how to see which MAC address belongs to the mkr1010, how can I figure that out? I haven't had any problems with this yet, so it seems unlikely. Should I turn dmz host on for it?

I tried googling the error but only seem to get one unrelated result... which doesn't bode well I feel, could something be wrong with my board?

Any help is appreciated.

Uploading the FirmwareUpdater sketch is only one step in the process of updating the firmware. You need to go through the entire process to update the firmware. It's documented here:

Please let me know if you have any questions.