Problem creating a new library

I am having a problem creating a new library–or getting the IDE to recognize the Test library from the Hacking/Libraries page.

I have created a directory in C:\arduino-0007\lib\targets\libraries\Camera that contains a Camera.cpp, Camera.h, and keywords.txt

I have also extracted the sample library to the same path (C:\arduino-0007\lib\targets\libraries\Test)

When I start the Arduino IDE (even after a reboot) and Goto Sketch/Import Library neither library shows up.

Am I missing something?

Hmm, the Test library works for me but I haven't tried it on Windows. Are you sure you're running the version of Arduino that's installed in that directory? Are the files names in all-caps (I think the extension needs to be ".h" with a lowercase h)? Do the other libraries show up in the menu? Are the Test or Camera libraries compiled (you'll see the .o files) when the Arduino environment starts?

This was the only version of Arduino installed on this machine. The file extensions were .cpp and .h (lowercase) respectively. The standard libraries show up but neither the Test or my Camera library. Neither the Test or my Camera library is compiled (no .o object files).

On another data point I installed the arduino software on another computer and copied the Camera library into the appropriate directory and it shows up in the arduino IDE. The only difference is that on this computer I installed the arduino software into the C:\Program Files directory. This is the standard install location for Windows software but since the arduino used a different install mechanism I didn't place it here on the other machine.

I wonder if the Windows version of the arduino software has the C:\Program Files hard coded as part of the root path?

Anyway I have a work around. Thanks for the help.

Weird. I don't think there are any hardcoded paths - and actually, things usually tend to work better when you install Arduino in the root of your drive rather than in Program Files. I wonder if it was some sort of permission issue. Did you install Arduino as a different user than the one that you installed the libraries as?

I don't think it is a permission issue. I have Win XP home edition on both machines. I don't have user accounts setup for either machine. The only permission/security I have installed is firewall software that is setup the same on both machines.

The machine that it worked on is a DELL E310 Desktop. The machine that it didn't work on is a DELL INSPIRON 1501 Laptop.

When I get a chance this week I plan to remove the arduino installation from the laptop and reinstall it under the Program Files directory structure. I'll let you know if it works.

I moved the arduino-0007 from the C:\ to C:\Program Files and the IDE found the new libraries. Not sure what could have caused this behavior.