problem in burning boot loader

http://arduino.cc/en/uploads/Tutorial/BreadboardAVR.png

i have connected everything as shown in the image. First uploaded arduino isp code.then choosed tools->burn bootloader what i have is Induino R3 which is a Arduino Rev3 Clone with a ATmega328 microcontroller loaded with Arduino UNO bootloader.so i choosed board->arduino uno and correct serial port

but i got error of

avrdude: Expected signature for ATMEGA328P is 1E 95 0F Double check chip, or use -F to override this check.

please help me to solve the problem.Thank you in advance

After you upload the ArduinoISP sketch you need to disable auto-reset. Put a 1 to 10 uF capacitor between the Reset pin (+) and the GND pin (-).

I had the same problem: the Arduino gets reset when a new serial connection starts and the attempt to burn a new bootloader looks to the UNO's bootloader just like an attempt to upload a new sketch (to replace ArduinoISP). The bootloader responds instead of giving control to ArduinoISP.

rather i had 120 ohm resistor between and reset and ground pin.Now i uploaded the bootloader successfully .Now i got another problem.if i plug the microcontroller in board it works fine and if take out and make it in bread board its shows error as

avrdude: stk500_getsync(): not in sync: resp=0x00

.what might be the problem.Thank you in advance

image http://arduino.cc/en/uploads/Tutorial/ArduinoUSBSerial.png

Maybe your crystal isn't wired properly.

no,i have used the same circuit for uploading bootloader,it worked now i just made some alteration like connecting tx,rx pins and reset pins.Thats all

i just replaced the resistor between reset and ground pin with capacitor(0.1uf) now it works fine as silk.i dont understand, with that resistor i did the burning bootloader but now i am using capacitor instead resistor for uploading sketch

I had a similar issue. Couldn't get it to work with a resistor whereas the capacitor worked first time.