Problem in uploading code to ardupilot atmega32

Just recently i got the ardupilot atmega328 board. It worked fine i test the version 2.0 and 2.1 on it. It worked nicely. But from past two days i could not load the program in my board it shows the message STK500 protocol:: not in sync
Expected reply :0x41 response :0x51
This is what arduino0016 shows me now.
I tested the FTDI cable its working well.
Please tell me how to test board.What could be the reason of not working.
Board behavior:

  1. It is not synchronising GPS.
  2. Yes Mux light is getting on and off with respect to wireless transmitter channel 5 mode.
  3. Not calibrating IR XY sensors.(There is no software in controller.).

If i off autopilot mode then MUX and MODE Led blinks after a intervals of time repeatedly.
5.
If autopilot is on then only MUX led gets on and nothing happens no serial output…
6
. When i load the program only Tx led blinks and no response from the controller to computer(RX led does not blink at all.)

  1. How to test Bootloader availability in my controller. and what for attiny45 is provided in board .
  2. How to test whether controller is safe (not blown out…).

Please Reply what could be the reason and the fast solution to the problem Thanks in advance to you all… :slight_smile: