Problem Installing DFRobot_TCS34725 library

Hello,

I'm slightly new to arduino.
I am making a project with the DFRobot TCS34725 Colour Sensor.
To use it, I tried including the library DFRobot gives at the bottom of this webpage:
https://www.dfrobot.com/wiki/index.php/TCS34725_I2C_Color_Sensor_For_Arduino_SKU:_SEN0212

However, when I did it, the Arduino IDE says that the zip file contains no library.

(Firstly I had to change the file DFRobot gives from .rar to .zip)

Could anyone try this to see if I am doing anything wrong?

Thank you in advance.

*sorry if I made any english grammar mistakes, I am not english native.
If i have not explained myself, please tell me.

kona:
(Firstly I had to change the file DFRobot gives from .rar to .zip)

How did you do that? You must have messed it up somehow during that process.

You should be aware that you can also manually install libraries, as explained here:

the "Add .ZIP library" installation method is convenient when the library is correctly packaged in a .zip file but if you have to go through all the trouble of creating a .zip file just to do the installation it's probably easier just to do a manual installation instead.

It's unfortunate that DFRobot doesn't have more care for their customers to make the library easier to install.

Thank you Pert for your early answer.

I had converted the file in a wrong way apparently. (I did: send to-- .zip file)

Now I tried an online .rar to .zip converter and it seems to have worked.

But yeah, don't understand why dfrobot gives the compressed file in .rar.

Thanks