Problem installing Nano in Windows 7

I have Arduino Nano v3 (Gravitech) which I was able to install on my laptop (Win 7 Pro 64-bit) using the FTDI drivers. Today, I moved my project to a new computer (Win 7 Pro 32-bit). Plugged the USB to one of the front ports and hardware was recognized automatically (COM 3). I was able to test my project but when I plugged the USB to one of the rear ports, the board wasn't recognized. I have updated the drivers with ones downloaded from FTDI but got an error message "Device could not be started. Code 10". So far I have tried the following:

  1. Uninstalled all COM ports. Windows finds all of them but still error code 10 on the Arduino board.

  2. Installed newest (beta) drivers from FTDI. Same problem.

  3. Tried three different USB cables including the original one I have used on my laptop. No go.

  4. Moved the project back to the laptop but now even the laptop doesn't even recognize the board.

Any ideas? Is the board shot?

Thanks.

I do not know what happened. Today when I plugged the Arduino board into USB port, it got assigned COM port and it started to work. I wish, I did not waste 2 hours yesterday trying to install/uninstall drivers. Hopefully tomorrow it will continue to work.