Problem installing USB drivers on vista


I've just got an arduino and have got into a mess with the USB drivers.

The first time I tried it I pressed the wrong button when the "new hardware found" box came up and it went off searching for updates.

I was typing as it finished and bad timing with me hitting the return key meant I didn't see whatever message it had flashed up!

I went into device managers, saw something with a yellow exclamation mark and uninstalling that meant I could start again with plugging in the arduino and getting the "new hardware found" window again. I've now tried all of the options and can't see a way to direct the wizard at the driver files on my machine. What should I have clicked?

I'm now also no longer getting the yellow exclamation mark under the device drivers so I no longer get a response from windows when I plug in the arduino.

Where should I go from here and/or how do I get back to the beginning again?

I'd be grateful for any help.


Solved. (not quite sure how, or would detail it here, but involved deleting things in device manager, letting vista install via updates, going back in through device manager and updating - that's what let me point to the driver folder - removing bluetooth devices to free up lower number ports....)

Glad you got it resolved nikki and thanks for posting solution here!