Problem interfacing R305 fingerprint module with arduino mega 2560

hello guys

i am working with my summer project and i am using R305 fingerprint module with arduino and currently i am facing problem while interfacing r305 fingerprint module with arduino mega :slightly_frowning_face:

i inserted the RX and TX pins of the r305 on the 10, 11 pins of the mega as mentioned in the adafruit forums and i have also mentioned the pins 10,11 instead of 2,3 in the enrollment code of the installed adafruit library but whenever i upload my program the serial monitor displays " did not find fingerprint sensor ". maybe mega 2560 doesnt detects the fingerprint sensor. i doubt whether this module is compatible with the board or not

i wish if you could just help me with the interfacing

This is the fingerprint sensor I assume : http://www.adafruit.com/product/751
It uses TTL Serial, that should work with the Mega 2560 board as well.

The Adafruit library uses the SoftwareSerial library. I assume that you have a line like this:

SoftwareSerial mySerial(2, 3);

But the Mega 2560 board does not allow SoftwareSerial on all pins. See the reference :

Pin 10 for RX and pin 11 for TX is good.

You should change the sketch also:

SoftwareSerial mySerial(10, 11);

Did you try that ? Could you try again ?

fingerprint module which i am using is this http://www.vegarobokit.com/index.php?route=product/product&product_id=505

but when i switched the pins from 2,3 to 10,11 it worked :smiley: :smiley: i uploaded enrollment and fingerprint matching examples from adafruit library finally detecting fingerprint sensor successfully

thanks a lot for the support and help :slight_smile:

and the fingerprint is more sensitive so i had to make sure all the wires were soldered and connected properly to the ports

"The Arduino Mega has three additional serial ports:
Serial1 on pins 19 (RX) and 18 (TX),
Serial2 on pins 17 (RX) and 16 (TX),
Serial3 on pins 15 (RX) and 14 (TX). "

With all those spare serial ports on the MEGA it is unnecessary to use SoftwareSerial which can conflict with other libraries.

johnwasser:
Serial - Arduino Reference
"The Arduino Mega has three additional serial ports:
Serial1 on pins 19 (RX) and 18 (TX),
Serial2 on pins 17 (RX) and 16 (TX),
Serial3 on pins 15 (RX) and 14 (TX). "

With all those spare serial ports on the MEGA it is unnecessary to use SoftwareSerial which can conflict with other libraries.

how to disable software serial since the library i used, also use that softwareserial library?

here is the error message when i disable #include softwareserial.h in my sketch :

In file included from Fingerprint_with_php110415.ino:40:0:
/home/rizal/Downloads/Packages/arduino-1.6.3/libraries/FPS_GT511C3/FPS_GT511C3.h:13:28: fatal error: SoftwareSerial.h: No such file or directory
 #include "SoftwareSerial.h"
                            ^
compilation terminated.
Error compiling.

Sir

I m still facing same problem in my r305 while interfacing to mega2560. I changed my serial pin 2,3 to10,11 .serial monitor is still displaying " fingerprint sensor didnt found". Some places, they suggested to use sfg demo fingerprint scanner software to interface but i didnt get any download link of it ..
Kindly help me

Pls mention all the connections you have tried from R305 to arduino (mega 2560 or UNO) including the voltage supply

and SFG demo software link http://www.nskelectronics.com/finger_print_scanner.html

Hi guys,
I am facing the same problem on interfacing the R 305 with arduino uno,It shows that "Did not find fingerprint sensor :(".I am using the adafruit library also it shows one more error that "WARNING: Spurious .github folder in 'Adafruit Fingerprint Sensor Library' library" on uploading the code to the board.

Pls help me to correct the errors..

Hi guys,
I am facing the same problem on interfacing the R305 with arduino uno it responds on the serial monitor as "Did not find fingerprint sensor :(".Also it shows one more error on uploading the code(i am using adafruit library) as"WARNING: Spurious .github folder in 'Adafruit Fingerprint Sensor Library' library".

Please help me to correct the error..

You may find a solution here: