Problem mit 200 mA-Beschränkung des Mega

Vielleicht eine dumme Frage, aber: sind die beiden Massen verbunden? Also der Minus-Pol der LCD-Stromversorgung an den GND-Pin des Arduinos angeschlossen?

Besorg dir ein ordentliches 5V-Netzteil, das alle verbraucher, auch den Arduino, versorgt. Ich verwende sowas hier:

http://www.reichelt.de/Universalnetzteile/MW-3K10GS/3/index.html?;ACTION=3;LA=2;ARTICLE=87339;GROUPID=4945;artnr=MW+3K10GS;SID=11UHPXeH8AAAIAAEKVK7Y6cceb8d90d2d1935cbc833ebd76259bd

für deine Heizungssteuerung könnte auch sowas interessant sein:

http://www.reichelt.de/Schaltnetzteile-Case-geschlossen/SNT-MW25-05M/3/index.html?;ACTION=3;LA=2;ARTICLE=66858;GROUPID=4959;artnr=SNT+MW25-05M;SID=11UHPXeH8AAAIAAEKVK7Y6cceb8d90d2d1935cbc833ebd76259bd

Wenn du mit einem Netzteil für Arduino und einem z.b. für dein LCD arbeitest, musst du die Massen verbinden, weil sonst der IC im LCD die Signale des Arduino nicht empfangen kann, weil kein "Steuerstrom" zwischen IC und Arduino fließt.

pylon: Vielleicht eine dumme Frage, aber: sind die beiden Massen verbunden? Also der Minus-Pol der LCD-Stromversorgung an den GND-Pin des Arduinos angeschlossen?

Guten Abend,

ehrlich gesagt, keine dumme Frage - habe ich nicht bedacht... Am Wochenende werde ich mich der Sache annehmen und berichten. Zuerst vielen Dank!

Grüße MIchael

Hallo circuit99,

Wenn du mit einem Netzteil für Arduino und einem z.b. für dein LCD arbeitest, musst du die Massen verbinden, weil sonst der IC im LCD die Signale des Arduino nicht empfangen kann, weil kein "Steuerstrom" zwischen IC und Arduino fließt.

Auch Dir danke für den Hinweis, ich werde nach der OP am laufenden Herzen berichten :-)

circuit99: Besorg dir ein ordentliches 5V-Netzteil, das alle verbraucher, auch den Arduino, versorgt.

Danke für den sehr konkreten Hinweis. Ich brauche 5V für die Relais etc. Einige schreiben hier, der Arduino sollte unter Last mit 7V versorgt werden (nachdem ich ihm 12V verpasst habe, und er heiß wurde, tendiere ich auch zu weniger).

Reichen 5V daher für das aufgesattelte Netzwerkshield und mit Sensoren?

Wie seht Ihr bitte die Mindestspannung?

Grüße Michael

Der Spannungsstabilisator und die Schutzdiode hinter der Netzteilbuchse des Arduino brauchen fast 2V damit sie korrekt funktioieren. Du kannst aber 5V am 5V pin einspeisen. Alle Verbraucher dann nicht über Arduino sondern die 5V und Masse direkt vom Netzteil, nicht über Arduino. Grüße Uwe

Hallo Uwe,

nur für mein Verständnis:
die 5V des Netzteils kommen in die Vin des Mega, GND auch. Dann kann ich meine Stromversorgung der Relais und Sensoren über die 5V-Buchse des Powerabschnittes oder auch direkt über vom Netzteil ziehen. Ist das bitte so korrekt?

Grüße
Michael

michael--g: Hallo Uwe,

nur für mein Verständnis: die 5V des Netzteils kommen in die Vin des Mega, GND auch. Dann kann ich meine Stromversorgung der Relais und Sensoren über die 5V-Buchse des Powerabschnittes oder auch direkt über vom Netzteil ziehen. Ist das bitte so korrekt?

Grüße Michael

Nein. Ich schrieb:

Du kannst aber 5V am 5V pin einspeisen.

Gemeint war der 5V Pin des Arduino. Die 5V für die Relais und andere Elektronik wie zB Hintergrundbeleuchtung direkt vom Netzteil. Grüße Uwe

Guten Abend,

die GNDs habe ich verbunden, die Kiste läuft noch immer - prima. Jetzt kann ich entspannt ins Bett gehen, da ich den Arduino nicht übermäßig belaste.

Leider hat sich das Problem der Schwankungen damit nicht mit erledigt. Aufgefallen ist mir aber Folgendes: Wenn ich alleine mit dem Netzteil (1000mA) die Sensoren und mein LCD versorge (GNDs dabei wie besprochen zusammengeschaltet), dann schwanken meine Meßwerte deutlich stärker als wenn es über den Arduino geht. Kann sich jemadn darauf bitte einen Reim machen?

Grüße Michael

Ich vermute mal daß das Netzteil ungenügend die Restwelligkeit beseitigt. Wenn Du die 5V mit eingeschaltenen Arduino und Display mißt auf dem wechselstromBereich des Multimeters mißt, was erhälst Du? Grüße Uwe

uwefed: Restwelligkeit ... Wenn Du die 5V mit eingeschaltenen Arduino und Display mißt auf dem wechselstromBereich des Multimeters mißt, was erhälst Du?

Aha, für mich jenseits der Schulphysik, mal gucken....

Spannung DC ist 5,09V AC 10,3V

Interessant - und was sagt uns das bitte?

Grüße Michael

Hast Du richtig gemessen?

wenn ja: Schmeiß sofort das Netzteil weg. Du reskierst den Arduino kaputzumachen. Versuchs mal an einem anderen Netzteil.

Grüße Uwe

Der Arduino hängt an einem Netzteil mit DC 7,4V AC 15,4V Die Angaben aus dem Posting vorher bezogen sich auf das Netzteil des LCD.

Die Kombination lief so seit paar Wochen.

Dennoch Grüße in leichter Panik Michael

Genaue Erklärung.

Im Wechselspannungsbereich mißt Du die der Gleichspannung von 5V überlagerte Wechselspannung. Diese rührt von einer ungenügenden Filterung (Kondensatoren zu klein) oder Spannungsstabilisation die nicht funktioniert.

Linke Grafik rote Kurve: Das ist eine Gleichspannung von ca 19V mit 0,7V Wechselspannung (Effektivwert, 2V Spitze Spitze). Wenn Deine Messungen richtig sind und Dein Meßgerät halbwegs Effektivwert anzeigt hast Du 5V mit riesigen Wechselspannungsanteil.

Ich habe aber ein Bißchen die Befürchtung, daß hier ein Meßfehler vorliegt, 10V AC sind einfach etwas sehr viel.

Welches Meßgerät hast Du? (Foto)

Grüße Uwe

Hmmm,

habe gerade ein paar Netzteile durchgemessen. Alle zeigen sie ca. im AC-Modus das Doppelte des DC-Wertes. Also entweder schrottiges Multimeter (was mind. im Rahmen des Möglichen bei mir wäre) oder Gedankenfehler.

Grüße Michael

Ich befürchte "schrottiges Multimeter" Kannst Du eines ausleihen oder mit Hilfe eines Besitzers Dein Netzteil nachmessen? Grüße Uwe

Wenn du das Display mit eigenem Netzteil versorgst hast du auch die Massen verbunden wenn nicht wird das dein Problem mit dem nichts anzeigen sein. Wenn man mehrere Versorgungen hat an einem Projekt müssen die Massen(GND) unbedingt verbunden sein. Gruß Der Dani

volvodani: Wenn du das Display mit eigenem Netzteil versorgst hast du auch die Massen verbunden wenn nicht wird das dein Problem mit dem nichts anzeigen sein. Wenn man mehrere Versorgungen hat an einem Projekt müssen die Massen(GND) unbedingt verbunden sein. Gruß Der Dani

Laut Schaldbild hat er die Massen verbunden. Grüße Uwe

Guten Abend,

endlich konnte ich nach einigen Tagen Pause mit dem Projekt weitermachen - und hier ist eine Lösung meines Schwankungsproblems!
LM35 sind die Sensoren, einige Meter vom Arduino entfernt. Ohne viele Worte zu verlieren: Glücklich, wer das Datenblatt lesen kann (ich war zuerst wegen der guten und “glatten” Ergebnisse in der Nähe des Arduino davon aisgegangen, dass ich nicht mehr an in der Richtung lesen/machen muss, vgl . Datenblatt des LM35, Fig 4., bei mir allerdings ohne Widerstand, wird glatter). Ein Kondensator zwischen Messleitung und GND wirkt Wunder!

Vielen Dank für Eure Beiträge. Auch wenn sie nicht einschlägig waren, habe ich daran viel gelernt!

Eine Frage hätte ich noch. SDL und SCA des I2C-Busses gehen auch über ziemlich lange Leitungen. Gibt es neben dem I2C-Extender noch eine andere Möglichkeit, Störeinflüsse wie bei meinem LM35 gesehen, zu reduzieren (das LCD Display prodziert manchmal seltsame (Sondern-) Zeichen).

Grüße
Michael

Einen I2C-Bus solltest Du tunlichst unter 1m halten. Kannst oder willst Du das nicht, gibt es noch die Möglichkeit, die Geschwindigkeit zu reduzieren, was die Störanfälligkeit heruntersetzt (der kapazitive Einfluss sinkt, die Flanken haben mehr Zeit, einen vernünftigen Wert zu erreichen).

Bei längeren Leitungen würde ich die Verwendung eines RS485-Busses vorschlagen, dem sollten auch einige Dutzend Meter nichts anhaben können.

Hallo Pylon,

danke für Deinen Hinweis. Ein paar Meter sind es bei mir schon - diese kann ich nicht überbrücken. Da mein "Sonderzeichenproblem" selten und unregelmäßig auftaucht, wäre ich für die Busgeschwindigkeit-Lösung. Hast Du bitte einen Tipp, wo ich nachlesen kann, wie das bewerkstelligt wird?

Viele Grüße Michael