Problem mit Arduino und dem16216 lcd

hallo, ich wollte mein arduino mit einem lcd ausstatten, habe mir folgendes geholt: http://www.display-elektronik.de/DEM16216SYH-LY.PDF. dann habe ich alles nach folgendem tutorial aufgebaut: http://www.ladyada.net/learn/arduino/lcd.html. Bis zum Test1 funktioniert auch alles wunderbar. das lcd geht an (schwarzer balken in erster zeile) und ich kann den kontrast über das poti regeln. leider ändert sich nichts nachdem ich das testprogramm hochlade. die kontroll led zeigt, dass das programm korrekt hochgeladen wurde, fehlermeldungen bei kompillieren oÄ gab es auch nicht. ich hab jetzt tausend mal alle kontakte überprüft und alle pinbelegungen in hard und software noch einmal überprüft. leider finde ich einfach keinen fehler. kann mir jemand vielleicht einen tipp geben wie ich dem fehler auf die spur gehen kann? eine art debugging anleitung? bin leider noch recht frisch was mikrocontroller angeht. Vielen Dank! unbezwingBART

kommt schon, traut euch. jeder hinweis ist willkommen^^. das problem besteht leider weiterhin :(

hmm es könnte durchaus sein, dass dieses LCD nicht mit einem Hitachi HD44780 Chipsatz kompatibel ist. Und deshalb funktioniert dein Aufbau nicht.

hmm es könnte durchaus sein, dass dieses LCD nicht mit einem Hitachi HD44780 Chipsatz kompatibel ist. Und deshalb funktioniert dein Aufbau nicht.

hmm, also ich hab die pinbelegungen etc schon auf mein lcd angepasst. es soll auch auf jeden fall mit diesem lcd fiunktionieren, haben andere schon hingekriegt :/

Hast du folgendes beachtet?

... Theres another control line called R/W that you can use to control whether you're reading or writing to the LCD. Since we'll just be writing, that pin can be connected to ground, saving another arduino pin ...

Ohne das du das Display in writemode setzt tut sich nix.

Habe dasselbe Display. Ich betreibe es im 4-Bit mode und es Funtkioniert nach anfänglichen Schwierigkeiten ohne Probleme.

http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1265369201

Habe es nach diesem Beispiel bedrahtet

http://arduino.cc/en/Tutorial/LiquidCrystal

Gruß Chris

kommt schon, traut euch.

Sorry, aber solche Aussagen sind hier nicht willkommen. [smiley=thumbdown.gif]

hmm es könnte durchaus sein, dass dieses LCD nicht mit einem Hitachi HD44780 Chipsatz kompatibel ist.

Genau, wenn ich im Datenblatt nachschaue, ist hier ein Typ ST7066U-0A im Diagramm auf Seite 6 dargestellt. Die Ansteuerung mit der verwendeten Bibliothek geht darum vermutlich nicht.

ST7066 is 44780 kompatibel. läufts mittlerweile? Falls nicht, meld dich. Bei mir läuft das Display.