Problem: Not able to upload to Arduino/Genuino Micro

Dear forum members

I recently picked up my old Arduino project and I’ve been running into countless problems and errors.
A friend and I are making a portable Arduino powered model rocket launch controller. I’m relatively new to Arduino but not to tinkering, coding or troubleshooting. So this post is like a last resort because I normally run into problems of which a solution is already posted somewhere on the internet.

Here we go:

  • First the Arduino IDE (version 1.8.1) wouldn’t open. This apparently was caused by the new nVidia driver (version 378.49 if I recall correctly) that didn’t like Java applications, e.g. Minecraft. This was fixed by installing an older version of the driver. More people might run into this problem, it’s because of this reason I mention the issue.

  • After I got the IDE working again and spend 8h coding I wanted to test my script. This led to the error message copied into the attachment. Trying to upload the blink script gave the same error message.

The error message can be found in the textfile I attached. It was too long to post it here.

java.io.IOException: Cannot run program “REMOVE/bin/avrdude”: CreateProcess error=2

What happens when I press the upload button:

  • The Arduino Micro is executing a blink script
    press upload button
  • The sketch is being compiled
  • The led on on the Arduino Micro turns off and starts to fade in/out for a few seconds (the thing it usually does)
  • The error message occurs
  • The Arduino Micro resets
  • The Arduino Micro continues to execute the blink script

System specifications:

  • Windows 8.1 Pro (64 bit)
  • nVidia driver version 376.33 (after downgrading)
  • Arduino IDE 1.8.1
  • Java 8u121 (32 bit and 64 bit)
  • Recently updated software: Microsoft Visual Studio 2015

Things I tried:

  • Searching on Google
  • Rebooting
  • Using a different USB port
  • Reinstalling the IDE (version 1.8.1)
  • Installing an older IDE (version 1.6.10)
  • Reinstalling Java (version 8u121, 32 and 64 bit)

The board used to run fine and there were no problems when interacting with my pc. The Arduino board is now running an old blink-like sketch which lets me test all the leds in my circuit.

Something else I noticed when trying to upload:
I selected COM3, but it tries to upload on COM4 I think. Not sure if my assumption is correct.

Can someone please help me with this issue?
Thanks in advance

Arduino_error.txt (29.8 KB)

Couple of quick points.

The NVIDIA drivers offering via updates from Microsoft almost always seems to break something and the best fix for that is to get the REAL drivers from NVIDIA themselves.

That it swapped from COM 3 to 4 is not such a deal breaker as some boards do that. The IDE looks at what you told it to compile for and then looks to match that to the COM port connect to that architecture (IIRC).

I see you are running win 8 in x86 installation. Going to guess that JAVA may have told you about a possible issue whilst installing the x64 version.

Going to guess its a brand name lappy or box as they tend to drop x86 in on a perfectly good x64 base.
Its not a real issue as the Arduino IDE is still x86 based (more the pity LOL)

You could start by trying this as it often has a good outcome

On Windows delete or rename both but you may have to turn on "hidden folders" to see it

C:\Users(username)\AppData\Roaming\Arduino15
C:\Users(username)\AppData\Local\Arduino15

Do a restart after that. and see if it helps. Those folders will be re-built BTW

I don't quite understand how, but it looks like that actually worked! Thanks.

I had a feeling it was going to be something easy to fix. I just couldn't find it.

The error referring to tools being located inside REMOVE happens due to the Arduino15 folder getting corrupted. It is not understood exactly what causes it.

Removing it and reinstalling the IDE is an effective fix.