Problem of connections between a laptop and an Arduino wifi shiled!!

Hi,

I am currently trying to create a wifi network (infrastructure one) using my laptop (no router) for my Arduino wifi shield (http://arduino.cc/en/Main/ArduinoWiFiShield) to connect to.

To do so, I use windows 7 functionality called "Microsoft Virtual Wifi Miniport Adapter" (http://virtualrouter.codeplex.com/) which permits me to create a virtual router on my laptop.
(Arduino wifi shield using the library Wifi.h can only connect to Infrastructure wifi network because it needs to have a DHCP server to give it its IP address.) so no ad hoc network possibility.

To create this virtual router I enter the following commands in the command prompt:
netsh wlan set hostednetwork mode=allow ssid=Arduino key=Arduino_mdp keyUsage=persistent
netsh wlan start hostednetwork
netsh wlan show hostednetwork

And I got this screenshot:

Paramètres du réseau hébergé

Mode : autorisé
Nom du SSID : « Arduino »
Nombre maximal de clients : 20
Authentification : WPA2 - Personnel
Chiffrement : CCMP

État du réseau hébergé

État : Démarré
BSSID : 00 :24 :d7 :ce :86 :15
Type de radio : 802.11g
Canal : 1
Nombre de clients : 0

And the command ipconfig gives me:

Carte réseau sans fil Connexion réseau sans fil 2 :

Suffixe DNS propre à la connexion. . . :
Description. . . . . . . . . . . . . . : Microsoft Virtual WiFi Miniport Adapter #2
Adresse physique . . . . . . . . . . . : 00-24-D7-CE-86-15
DHCP activé. . . . . . . . . . . . . . : Oui
Configuration automatique activée. . . : Oui
Adresse IPv6 de liaison locale. . . . .: fe80::e1fb:bb79:8f8f:191c%17(préféré)
Adresse IPv4. . . . . . . . . . . . . .: 192.168.173.1(préféré)
Masque de sous-réseau. . . . . . . . . : 255.255.255.0
Passerelle par défaut. . . . . . . . . :
IAID DHCPv6 . . . . . . . . . . . : 570434775
DUID de client DHCPv6. . . . . . . . : 00-01-00-01-18-B0-28-94-10-1F-74-52-90-41
Serveurs DNS. . . . . . . . . . . . . : fec0:0:0:ffff::1%1
fec0:0:0:ffff::2%1
fec0:0:0:ffff::3%1
NetBIOS sur Tcpip. . . . . . . . . . . : Activé

My problem is that I cannot make my Arduino Wifi shield to connect to it.
I have succeeded to make a connection between an Iphone and this network.
And I have succeeded to make a connection between my Arduino Wifi shield and some routers and Internet hotspots.
So I pretty sure it is network related.

Does anyone have a solution?
Is there an other way to create a wifi network (infrastructure) using a laptop?

Thanks in advance!!

RemiP

Up !
Please, somebody ? :confused: