Problem programming an Atmega8L using Arduino as ISP

As the title says. I want to program an Atmega8L using Arduino as ISP. I have downloaded the miniCore to add boards. But this core does not support 8L i think. I get below error when i want to burn bootloader. I would upload the code after burning the bootloader, but as burning itself fails, i don't know what to do. I am not using external oscillator.

Error messae when burning bootloader -

Arduino: 1.6.11 (Windows 10), Board: "ATmega8, 1MHz internal  (BOD 2.7v)"

avrdude: Yikes!  Invalid device signature.
     Double check connections and try again, or use -F to override
     this check.

Error while burning bootloader.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

Error when uploading code -

Arduino: 1.6.11 (Windows 10), Board: "ATmega8, 1MHz internal  (BOD 2.7v)"

Sketch uses 872 bytes (11%) of program storage space. Maximum is 7,680 bytes.
Global variables use 9 bytes (0%) of dynamic memory, leaving 1,015 bytes for local variables. Maximum is 1,024 bytes.
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0xff
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0xff
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0xff
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0xff
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0xff
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0xff
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0xff
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0xff
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0xff
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0xff
An error occurred while uploading the sketch

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

The question is also posted here - http://electronics.stackexchange.com/questions/267395/program-an-atmega8l-by-arduino-as-isp

avrdude: Yikes! Invalid device signature. Double check connections and try again, or use -F to override this check.

The device signature on you device seems to be wrong. Turn on verbose upload in the IDE settings, and pust your result again. if the device ID is 0x000000, the chip doesn't respond, and there's something wrong with the wiring or clock source. A picture of your setup is always helpful :)

Cross-posted at http://electronics.stackexchange.com/questions/267395. PLEASE DON'T DO THAT!!!. It's very disrespectful to the users of this forum and Stack Exchange because it wastes our time due to duplicate effort. At least you could have added a link to the other places where you posted the question.

Here is schematic of my setup. I do not have a good camera so posting fritzing image.

|500x395

Now i can burn bootloader. Apparantly the AVCC was not properly connected. But still can not upload sketches to the Atmega8L. I get the following error, which is same as before -

Arduino: 1.6.11 (Windows 10), Board: "ATmega8, 1MHz internal  (BOD 2.7v)"

Sketch uses 872 bytes (11%) of program storage space. Maximum is 7,680 bytes.
Global variables use 9 bytes (0%) of dynamic memory, leaving 1,015 bytes for local variables. Maximum is 1,024 bytes.
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0xff
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0xff
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0xff
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0xff
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0xff
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0xff
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0xff
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0xff
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0xff
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0xff
An error occurred while uploading the sketch

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.