Problem SIM900 DB:ELSE please help!

Hello,
i have connected an arduino mega to this SIM900L, to test sending SMS with SIM900 library, but it did not send the SMS, i checked the serial results, and for some reason am getting DB:ELSE , the SIM900 module seems to work fine, but for the life of me i could not figure out why is this happening, it was supposed to be straight forward, following is my code

#include "SIM900.h"
#include <SoftwareSerial.h>
#include "sms.h"
SMSGSM sms;
int numdata;
boolean started=false;
char smsbuffer[160];
char n[20];
char sms_text[100];
char phone_num[20]="+999999999";
void setup()
{
     Serial.begin(9600);
     Serial.println("GSM Shield testing.");
     if (gsm.begin(2400)) {
          Serial.println("\nstatus=READY");
          started=true;
     } else Serial.println("\nstatus=IDLE");
     if(started) {
          //Enable this two lines if you want to send an SMS.
          if (sms.SendSMS("+999999999", "Arduino SMS"))
          Serial.println("\nSMS sent OK");
     }
};

void loop()
{
     if(started) {
      sms_position=sms.IsSMSPresent(SMS_UNREAD);
          if (sms_position) 
        {
          sms.GetSMS(sms_position, phone_num,20, sms_text, 100);
          Serial.println("DEBUG SMS phone number: ");
            Serial.println(phone_num);
            Serial.println("SMS text: ");
            Serial.println(sms_text);
        }    
          delay(5000);
     }
};

when i run the serial monitor am getting the following results, and no SMS is being sent!:
GSM Shield testing.
ATT: OK
RIC: AT

ATT: OK
RIC: AT

ATT: OK
RIC: AT

ATT: OK
RIC: AT

ATT: OK
RIC: AT

DB:ELSE
ATT: OK
RIC: AT

ATT: OK
RIC: AT

ATT: OK
RIC: AT

ATT: OK
RIC: AT

ATT: OK
RIC: AT

DB:ELSE

DB:AUTO BAUD RATE
ATT: OK
RIC: AT

ATT: OK
RIC: AT


same lines

DB:NO BR
ATT: OK
RIC: AT

ATT: OK
RIC: AT

ATT: OK
RIC: AT

ATT: OK
RIC: AT

ATT: OK
RIC: AT

DB:NO BR
ATT: OK
RIC: AT

ATT: OK
RIC: AT

ATT: OK
RIC: AT

ATT: OK
RIC: AT

ATT: OK
RIC: AT

DB:NO BR
Trying to force the baud-rate to 9600

1200
ATT: OK
RIC: AT+IPR=9600
AT

ATT: OK
RIC: AT

ATT: OK
RIC: AT

ATT: OK
RIC: AT

ATT: OK
RIC: AT

same lines

ERROR: SIM900 doesn’t answer. Check power and serial pins in GSM.cpp

status=IDLE

please help.