Problem Uploading ---> avrdude: stk500_recv(): programmer is not responding

Hi, I have Ubuntu Lucid 10.04 LTS with arduino 018 installed. And I have Duemilanove 2009. Well I have worked with Arduino very well in the past with Windows and now after 3 months of gap when I tried to upload the program on Ubuntu it shows:

avrdude: stk500_recv(): programmer is not responding and Problem uploading to board. See http://arduino.cc/en/Guide/troubleshooting#upload.

[ I have selected Tools>Board> Arduino Duemilanove and Tools>Serial Port>/dev/ttyUSB0 ] Note: Bootloader works fine. [ On connecting PC with Duemilanove, LED[pin 13] blinks ]

And when clicked on upload button, RX Led blinks but then TX Led doesn't blink. And shows the message above. Checked the cable also, doesn't work.

With verbose output true, it shows: " avrdude -v -v -v -v -patmega328p -carduino -P/dev/ttyUSB0 -b57600 -D -Uflash:w:/tmp/build5385409013457240616.tmp/Blink.cpp.hex:i

avrdude: Version 5.10, compiled on Mar 23 2010 at 15:03:00 Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/ Copyright (c) 2007-2009 Joerg Wunsch

System wide configuration file is "/etc/avrdude.conf" User configuration file is "/root/.avrduderc" User configuration file does not exist or is not a regular file, skipping

Using Port : /dev/ttyUSB0 Using Programmer : arduino Overriding Baud Rate : 57600 avrdude: Send: 0 [30] [20] avrdude: Send: 0 [30] [20] avrdude: Send: 0 [30] [20] avrdude: ser_recv(): programmer is not responding avrdude: stk500_recv(): programmer is not responding

avrdude done. Thank you. " Kindly Help. Thank You. --Arpan

You have FDTI drivers installed?

If you're updating Ubuntu automatically (as you should be doing) you may have run into the same bug that I did: 2.6.35-25 and 2.6.35-27 don't seem to like the FTDI / Arduino combination very much. To check which version of the kernel you're using, try going to a terminal and typing uname -a You should get output something like this: mxedisn@closet2:~$ uname -a Linux closet2 2.6.35-24-generic-pae #42-Ubuntu SMP Thu Dec 2 03:21:31 UTC 2010 i686 GNU/Linux mxedisn@closet2:~$ If you're running 2.6.35-25 or later, try rebooting an earlier kernel. (To do this, hold down the shift key shortly after POST and select an earlier kernel from GRUB's menu..)

Hope this helps.

MarkT: Well how can I check FTDI drivers are installed or not in ubuntu. I checked with command lshw but nothing there of FTDI.

dsacmul: I have never updated the ubuntu or its kernel. It's default installed by Ubuntu 10.04 iso CD. And uname -a shows this Linux Appu-Z 2.6.32-21-generic #32-Ubuntu SMP Fri Apr 16 08:10:02 UTC 2010 i686 GNU/Linux

The command to show the usb devices is lsusb

Here what mine look like for Duemilanove.
Bus 005 Device 004: ID 0403:6001 Future Technology Devices International, Ltd FT232 USB-Serial (UART) IC

and for Uno
Bus 005 Device 006: ID 2341:0001

The command dmesg will also give information.