Problem uploading blink program to due

I have used the Arduino Uno a lot in the past. I recently got an Arduino Duemilanove, and when trying to upload the blink program from my windows 8 computer, I get an error:

avrdude: Version 5.11, compiled on Sep  2 2011 at 19:38:36
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2009 Joerg Wunsch

         System wide configuration file is "F:\Program Files (x86)\Arduino\hardware/tools/avr/etc/avrdude.conf"

         Using Port                    : \\.\COM3
         Using Programmer              : arduino
         Overriding Baud Rate          : 57600
avrdude: Send: 0 [30]   [20] 
avrdude: Send: 0 [30]   [20] 
avrdude: Send: 0 [30]   [20] 
avrdude: Recv: 
avrdude: stk500_getsync(): not in sync: resp=0x00

avrdude done.  Thank you.

I have already installed the FTDI drivers and assigned them to the arduino. The Arduino IDE sees the device's port COM3, but fails to upload. I have also already tried pressing the reset button right before uploading, and that failed as well. I have searched on google for an answer, but the solutions I found dont seem to work. Any ideas?

Are you sure you have the Diecimila with the ATmega328P processor? The one with the ATmega168 apparently uses a different upload baud rate, That would prevent the upload from working.

Hold down the Reset button and start the upload. When the RX LED blinks release the button.

Thanks for the response, but the reset button didn't work. My guess is that the bootloader may not be there. I may have been an idiot and erased it, since I pressed the erase button on the board. I thought that that button erased the arduino sketch, not the bootloader, but correct me if I'm wrong.

The reason I think I'm missing the bootloader is that when I press the reset button on my due, none of the LEDS flash.

And my board is a 328, not a 168

The Duemilanove is not the same as a Due.

The Duemilanove doesn't have an erase button, but the Due does...

Hamhock666:
And my board is a 328, not a 168

Not if it is a Due...

Yes, sorry for the confusion, I thought one was the abbreviation for another, especially when the proccessor said sam3x8 on it. But either way, I am still not sure if it is the bootloader or not that is causing my problems. How do I tell if I have a bootloader, and what does the erase button do?

image.jpg

Hamhock666:
... and what does the erase button do?

Did you not even look at the description page I linked you to?

From the page I linked to above:
"It is possible to erase the Flash memory of the SAM3X with the onboard erase button. This will remove the currently loaded sketch from the MCU. To erase, press and hold the Erase button for a few seconds while the board is powered."

Based on your AVRDUDE output, you've still selected Duemilanove or Uno. You have to select "Due", which is on the bottom of the 1.6.x's board list.

Also realize the Due runs at 3.3V and is not 5V tolerant on the I/O pins.

I'd also recommend editing your initial post, so that others aren't confused when they try to help.

Thank you so much for your help, it worked, just had to install the arduino due board package in the arduino IDE. Sorry for my incompetence on the forum.

You aren’t the first to make that mistake. It was an unfortunate decision to name it so similar.