Problem uploading sketch to Nexus 4WD 10009 robot kit

Hi

I'm working with this robot kit:

Its main board is:
https://www.vstone.co.jp/robotshop/index.php?main_page=product_info&products_id=3829
User manual:

I tried to upload blink example with no success.
I tried both Online IDE and Desktop IDE in Windows and Ubuntu 16.04.

I got following error every time:

Sketch uses 928 bytes (3%) of program storage space. Maximum is 30720 bytes.
Global variables use 9 bytes (0%) of dynamic memory, leaving 2039 bytes for local variables. Maximum is 2048 bytes.
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x00
Problem uploading to board. See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.

I tried setting controller as Atmega328 and tried setting board as Nano, Duemilanove and Diecimila.
When I run Tools->Get Board Info, I got following:

BN: Unknown board
VID: 0403
PID: 6001
SN: Upload any sketch to obtain it

Does anyone have experience working with this kit?
Does it come with proper bootloader?

Can you tell me what is the problem here?

Sure thing. You failed to follow these instructions.

Problem uploading to board. See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.

If you HAD, you'd know where to post your thread - it is NOT a Robotics issue - AND you'd know to answer a boat-load of questions without needing to be asked.

The issue is that the JUMPER bridge on the extension board named RS 485 is set. You have to remove it to enable serial communication via USB. See also here: https://translate.google.com/translate?hl=de&sl=auto&tl=de&u=https%3A%2F%2Fwww.vstone.co.jp%2Fproducts%2Fnexusrobot%2Fqa.html

Also you need the right driver for the FT232R USB serial chip on the board. https://www.ftdichip.com/Drivers/CDM/CDM21228_Setup.zip.
After it you can run e.g. Arduino Studio by selecting the right COM Port with and as Board Arduino Duemilanove.

Or you can run following command: avrdude -v -v -v -v -CD:"\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf" -v -patmega328p -carduino -PCOM3 -b57600 -D -Uflash:w:C:\RB009_RB008_Omni4WD_PID.ino.hex:i