Problem uploading sketches

Hi, Please help me
I am using Arduino Uno board with blink example.
the Blink program code is getting compiled but giving error while uploading to board
following is the error message
"avrdude: stk500_getsync(): not in sync: resp=0x00"
"avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x00"
my board is getting detected as 'COM9' when connected using USB cable
Thank you

So have you chosen the right processor from the menu?
What Arduino model do you have?
Have you done all the things in the sticky post?

yes, I had selected Arduino Uno from the menu and then selected the com port COM9 then tried the upload!

And done everything at:-
http://www.arduino.cc/en/Guide/Troubleshooting#upload

The message:-
"avrdude: stk500_getsync(): not in sync: resp=0x00"
means that the computer has asked to get in contact with your processor and the processor did not answer.

You could try reloading the boot loader in the processor chip. Did it ever work and it has now stopped?

"avrdude: stk500_getsync(): not in sync: resp=0x00"
usually indicates the microprocessor is not sending data to the USB/Serial adapter chip.

Could be a missing bootloader.

"avrdude: stk500_getsync(): not in sync: resp=0x00"

Yesterday I was getting same error message while using an FTDI breakout board for uploading sketch to an ATMEga chip on breadboard. Then I removed the 328p chip from another Arduino board & used the inbuilt ftdi of the uno board as serial interface, it worked.

Hi! If the the boot loader is missing how to re install the same for arduino Uno board in which Atmega328 microcontroller is existing?
kindly reply with procedure to upload the bootloader. where can i get it? I am using the standard USB to serial cable for interfacing the board with my PC

You need a programmer of some sorts, an Arduino will do.

where can i get it

The Arduino IDE already contains the bootloaders for all the different versions of the Arduino.

kindly reply with procedure to upload the bootloader

https://learn.sparkfun.com/tutorials/installing-an-arduino-bootloader

Your Arduino probably has a counterfeit FTDI chip. Download and install an older version of the driver.

http://forum.arduino.cc/index.php?topic=198681.msg1477473#msg1477473

I had the same issue, yesterday my arduino uno was working and today I couldnt upload any sketches. After trying multiple things and checking everything I tried to switch to a different board in the IDE just to see what would happen before I would burn the bootloader. I switched it to the duemilanove w/ Atmega328 and that solved the problem, but Im still getting the error when I try to upload with the uno board selected. So it is a solution, but not a permanent one. If someone has an idea why this happens please tell me because Im clueless.

Perhaps your computer updated the FTDI USB driver. Did you read the link to the other thread I posted?

I will try that and see if that works :wink: