Problem uploading - stk500_getsync(): not in sync: resp=0xe0

Good evening,
I’m new in this forum, I’m from Paraguay and I had recived my first arduino board 4 days ago. However, when I try uploading a sketch in my arduino duemilanove with atmega 328 I get the following error.

  • stk500_getsync(): not in sync: resp=0xe0

I tried the following acctions to solve the problem

  • Verify that the right port is choosen (windows7/Ubuntu 11.04)
  • Verify that the right board is choosen (windows7 32, 64/Ubuntu 11.04)
  • Update the driver (windows7 32, 64)
  • Change the atmega328 chip for an other atmega328 (windows7 32, 64/Ubuntu 11.04)
  • Change the USB cable (windows7 32, 64/Ubuntu 11.04)

but I get the same error… :frowning:
The 2 atmega 328 chips aparently are functional, because one of them blinks the pin 13 when is conected and the other one sends an output which can be viewed on the serial monitor.
I hope you can help me…

Pictures of my arduino and its chip



Is it possible that someone burned an optiboot (UNO) bootloader on your chips? Try selecting the Arduino UNO board to see if that works.


I just bought a Arduino Mega2560 rev3 and I did not want to use the arduino software with sketches etc. I want to use AVR Studio 5 with visual studio. I also had this error with uploading with avr dude and searched the internet for solution.

I found a solution:

Make a .bat file and put this in and replace de directory names etc to match your computer.
and change the last option -UFlash to -Uflash:w:yourhexfile2upload.hex:i

/*bat file */
G:\Downloads\arduino-0022\arduino-0022\hardware/tools/avr/bin/avrdude -CG:\Downloads\arduino-0022\arduino-0022\hardware/tools/avr/etc/avrdude.conf -v -v -v -v -patmega2560 -cavrispmkII -P\.\COM3 -b115200 -D -Uflash:w:G:\Development\Arduino\Projects\General_Test_Project\General_Test_Project\Debug\General_Test_Project.hex:i
/*end bat file */

Then click the reset button on Arduino and immidiatly double clik the bat file and the arduino is uploaded.
My Arduino is cennected with serial cable on COM3.

Works every time!

Spread this solution...please


I'm too very new in this field, just purchased Uno Rev 3, run first blink Led demo and it worked very fine. changed in parameters of blinking and delay timings and that too worked fine. After i closed it, Arduino 1.0, now even with same program of blinking led, when i compile/run it works, it uploads too with done uploading and after that following error and new program is not working, old program which was worked fine, still runs fine on board but can't upload it again due to this error.

avrdude: stk500_getsync(): not in sync: resp=0x00

Now, with little knowledge of electronics and very new to Arduino, can't solved this error.

Can anybody please let me help where to look or what can be my mistake ?

Thank you moderators for posting my older post regarding error. But looking to verbose (File-Preference-Verbos) i instantly figured out that, there was common (Tools-Serial Port-Com8) which was already used by Arduino board too. So I changed to any other available (Tools-SerialPort-Com13) and my program/sketch worked fine. I think i may have changed it accidently !!!

Again, posting so that another users may get some help.

Good morning
Thank you for your reply.
I’ve tried your suggestions, but I get the same error…

this is what I did this time:

  • I chose arduino UNO instead arduino duemilanove
  • I executed .bat field (see attachment for more details)

I’ve attached the print screen of the folowing items:


From the output of the batch file (you can get the same in the IDE by selecting 'Show verbose output during: [ ] compilation [X] upload' in Preferences...) it looks like the Arduino is not responding at all. Have you tried a loopback test to see if your USB-to_Serial is working in both directions? The instructions are here: Arduino Forum

Thank you for your reply.
I’ve tried your suggestion. I followed the instructions in,73748.0.html and I haven’t received any echo from the arduino, in the serial monitor.

I’ve attached the picture of my arduino with:

  • the jumper from RESET to GND
  • the jumper from TX to RX


So the USB-to-Serial isn't working properly. Next step is to refresh the USB-to-Serial firmware:

Thank you very much for your sugestions, all of you have been very nice with me.

However, I've decided not to refresh the firmware, because it might void the warranty I have from the store I bought it.

Regards from Paraguay