Problem uploading to Arduino Mini r5 w/ ATMega328 (5v)

Hi all,

I have an arduino Leonardo that I program to make sure my code is ok, in any case, for the purpose of testing I am just using Blink. Programming the Leonardo goes without a hitch.

My problem is with my Arduino Mini r5 w/ ATMega328 (5v). I am connecting to it using one of these modules:

http://www.ebay.co.uk/itm/FT232RL-FTDI-USB-to-TTL-Serial-Adapter-Module-for-Arduino-Mini-Port-3-3V-5-5V/181289723101?_trksid=p5197.c100068.m2280&_trkparms=aid%3D222006%26algo%3DSIC.FITP%26ao%3D1%26asc%3D20140205155511%26meid%3D7035777458984438611%26pid%3D100068%26prg%3D20140205155511%26rk%3D1%26rkt%3D6%26sd%3D181289507169%26clkid%3D7035797411736328965&_qi=RTM1793699

with RX connected to TX and TX to RX, the reset pin on the USB adapter connected to the reset on the mini, which is pulled high with a 10kOhm resistor connected to VCC. When I first plug it in, if I put an LED on pin 12, then there is a fairly rapid on-off blink, maybe 0.5 to 0.3s, I am not sure exactly. The USB registers as being on COM2, and I set the board to Arduino Mini w/ ATMega328, hit upload, the code compiles and

avrdude: stk500_getsync(): not in sync: resp=0x00

I'm aware this is a communications issue between the computer and mini. I am at my wits end now though. I have checked the little FTDI module, checked the drivers and windows assures me that the driver is up to date. I've tried pressing reset just before I hit upload, I've tried pressing reset just after I hit upload, I have tried a load of different board options (Arduino Uno for example) just in case the bootloader is wrong, but I really have no clue. Can anyone see anything I'm missing?

oh, for reference, I have a Lilypad Arduino here that I have programmed with the same USB connector (plus a bit of cabling) and that works fine (changing tools->board Lilypad Arduino w/ AT328)

I've solved it. By just connecting the reset on the mini to 5V via a resistor, and then clicking 'upload', waiting until it finishes compiling the sketch and then when the bar says 'uploading' then I click on the reset button on the mini.

the timing on the various tutorials I have read was a bit vague as to when to hit reset.