Problem uploading to board. avrdude: stk500_getsync()

Hello friends,

I am having yet the same problem a lot of people on this forum have or had. I am using an elegoo Uno R3 that i bought recently from amazon. I have been using the board for a couple days and everything seemed fine, where i was able to upload to the board from the arduino IDE just fine. I played with the blink program and everything worked fine, until yesterday. Now i am confused where I could have gone wrong. I was playing with some LED lights and i plugged my Elegoo board into an AC/DC adapter, which i now realize, the adapter outputs 12V, which could have possibly fried some thing on the board, however the lights on the board work fine, and i was able to upload one final RGB LED program before the board became unresponsive to my Windows 10 PC. So here are my problems now:
-Windows 10 states that last USB device connected Malfunctioned and windows does not recognize it.

  • I receive the message 'avrdude: stk500_getsync() attempt # of 10: not in sync: resp=0x69'
  • i checked device manager and it states 'Unknown USB Device (Device Descriptor Request Failed)', driver does not need an update either.
  • I tried uninstalling the USB device then unplugging the board, holding the reset button, then reconnecting the board and releasing the reset button.
  • In arduino IDE, board is selected as Arduino Uno and Port is COM1
  • I have tried connecting arduino and uploading blink program from a mac book, still same problem.

So i am not sure whether the board is fried or not, because the lights are on, but unresponsive to my PC. If you need any more information I will be replying quickly.

Thank you to anyone who takes their time to help.

So you have one of these?
https://www.elegoo.com/product/elegoo-uno-r3-board-atmega328p-atmega16u2-with-usb-cable/

(How does elegoo stay in business? They show everything but 1 item as Sold Out.)

It's highly likely the '16u2 chip near the USB connector got fried, they do seem to be delicate.

If you have a Programmer, that connects to the 2x3 headers on the boards, you could try re-programming it and see if that helps, but that is a bit advanced for most people.
If the chip IS dead, than you've lost debug capability via Serial.print() as well.

You could use an FTDI Basic
(or equivalent, ex: https://www.tinyosshop.com/index.php?route=product/product&filter_name=ftdi&filter_description=true&filter_sub_category=true&product_id=186)
to connect to the Rx/Tx lines for a serial interface instead as long as the Bootload code on the '328P is still running.

It's good to have a couple of 'tools' like that handy.
I have an older AVRISP MKii Programmer (that I bought from Atmel when they still sold them) that I use a lot to install Bootload code, and to use Upload Using Programmer when I don't want bootload code to run on startup, but prefer to have the code start immediately:
https://www.tinyosshop.com/index.php?route=product/product&filter_name=programmer&filter_description=true&filter_sub_category=true&product_id=74